[backfire/packages] libspe2: remove, backfire has no ps3 target
authorNicolas Thill <nico@openwrt.org>
Thu, 13 Oct 2011 17:20:33 +0000 (17:20 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 13 Oct 2011 17:20:33 +0000 (17:20 +0000)
SVN-Revision: 28445

libs/libspe2/Makefile [deleted file]
libs/libspe2/patches/001-remove_tls_requirement.patch [deleted file]

diff --git a/libs/libspe2/Makefile b/libs/libspe2/Makefile
deleted file mode 100644 (file)
index 2fc4aa4..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-# 
-# Copyright (C) 2006-2008 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=libspe2
-PKG_VERSION:=2.3.0
-PKG_MINOR_VERSION:=135
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).$(PKG_MINOR_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/libspe
-PKG_MD5SUM:=c77dc69d3585d45f980e661232ae2b0b
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/libspe2
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE:=SPE Runtime Management Library for the Cell Broadband Engine
-  DEPENDS:=@TARGET_ps3||TARGET_ps3chk
-  URL:=http://sourceforge.net/projects/libspe/
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" SYSROOT="" CROSS=$(TARGET_CROSS) all install
-endef
-
-define Build/InstallDev
-       echo "Build/InstallDev"
-       $(INSTALL_DIR) $(1)/usr/include
-       $(CP)   $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP)   $(PKG_INSTALL_DIR)/usr/lib/libspe2* $(1)/usr/lib/
-endef
-
-define Package/libspe2/install
-       echo "Package/libspe2/install"
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libspe2* $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,libspe2))
diff --git a/libs/libspe2/patches/001-remove_tls_requirement.patch b/libs/libspe2/patches/001-remove_tls_requirement.patch
deleted file mode 100644 (file)
index ae4d118..0000000
+++ /dev/null
@@ -1,93 +0,0 @@
---- libspe2-2.3.0.old/spebase/run.c    2008-10-28 14:43:09.000000000 +0100
-+++ libspe2-2.3.0/spebase/run.c        2008-10-28 14:44:07.000000000 +0100
-@@ -37,6 +37,7 @@
- #include "spebase.h"
- #include "regs.h"
-+#if 0
- /*Thread-local variable for use by the debugger*/
- __thread struct spe_context_info {
-       int spe_id;
-@@ -44,13 +45,15 @@
-       unsigned int status;
-       struct spe_context_info *prev;
- }*__spe_current_active_context;
-+#endif
--
-+#if 0
- static void cleanupspeinfo(struct spe_context_info *ctxinfo)
- {
-       struct spe_context_info *tmp = ctxinfo->prev;
-       __spe_current_active_context = tmp;
- }
-+#endif
- static int issue_isolated_exit(struct spe_context *spe)
- {
-@@ -69,12 +72,14 @@
-       return 0;
- }
-+#if 0
- static inline void freespeinfo()
- {
-       /*Clean up the debug variable*/
-       struct spe_context_info *tmp = __spe_current_active_context->prev;
-       __spe_current_active_context = tmp;
- }
-+#endif
- int _base_spe_context_run(spe_context_ptr_t spe, unsigned int *entry,
-               unsigned int runflags, void *argp, void *envp,
-@@ -83,7 +88,9 @@
-       int retval = 0, run_rc;
-       unsigned int run_status, tmp_entry;
-       spe_stop_info_t stopinfo_buf;
-+#if 0
-       struct spe_context_info this_context_info __attribute__((cleanup(cleanupspeinfo)));
-+#endif
-       /* If the caller hasn't set a stopinfo buffer, provide a buffer on the
-        * stack instead. */
-@@ -146,6 +153,7 @@
-                       return -1;
-       }
-+#if 0
-       /*Leave a trail of breadcrumbs for the debugger to follow */
-       if (!__spe_current_active_context) {
-               __spe_current_active_context = &this_context_info;
-@@ -162,18 +170,23 @@
-       }
-       /*remember the ls-addr*/
-       __spe_current_active_context->spe_id = spe->base_private->fd_spe_dir;
-+#endif
- do_run:
-+#if 0
-       /*Remember the npc value*/
-       __spe_current_active_context->npc = tmp_entry;
-+#endif
-       /* run SPE context */
-       run_rc = spu_run(spe->base_private->fd_spe_dir,
-                       &tmp_entry, &run_status);
-+#if 0
-       /*Remember the npc value*/
-       __spe_current_active_context->npc = tmp_entry;
-       __spe_current_active_context->status = run_status;
-+#endif
-       DEBUG_PRINTF("spu_run returned run_rc=0x%08x, entry=0x%04x, "
-                       "ext_status=0x%04x.\n", run_rc, tmp_entry, run_status);
-@@ -341,6 +354,8 @@
-       }
-+#if 0
-       freespeinfo();
-+#endif
-       return retval;
- }