[package] ppp: mark /etc/ppp/ resources as conffiles
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 5 Oct 2010 17:13:07 +0000 (17:13 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 5 Oct 2010 17:13:07 +0000 (17:13 +0000)
SVN-Revision: 23248

package/ppp/Makefile

index 4107ef68645dc338403c3498c3f9cf4b9b19d764..cab220a3e322b0756d544fe446c78498922bf83b 100644 (file)
@@ -40,6 +40,16 @@ define Package/ppp/description
 This package contains the PPP (Point-to-Point Protocol) daemon.
 endef
 
 This package contains the PPP (Point-to-Point Protocol) daemon.
 endef
 
+define Package/ppp/conffiles
+/etc/ppp/chap-secrets
+/etc/ppp/filter
+/etc/ppp/ip-down
+/etc/ppp/ip-up
+/etc/ppp/ipv6-down
+/etc/ppp/ipv6-up
+/etc/ppp/options
+endef
+
 define Package/ppp-mod-pppoa
 $(call Package/ppp/Default)
   DEPENDS:=ppp +linux-atm +kmod-pppoa
 define Package/ppp-mod-pppoa
 $(call Package/ppp/Default)
   DEPENDS:=ppp +linux-atm +kmod-pppoa
@@ -71,6 +81,14 @@ This package contains a RADIUS (Remote Authentication Dial-In User Service)
 plugin for ppp.
 endef
 
 plugin for ppp.
 endef
 
+define Package/ppp-mod-radius/conffiles
+/etc/ppp/radius.conf
+/etc/ppp/radius/dictionary
+/etc/ppp/radius/dictionary.asnet
+/etc/ppp/radius/dictionary.microsoft
+/etc/ppp/radius/servers
+endef
+
 define Package/chat
 $(call Package/ppp/Default)
   DEPENDS:=ppp
 define Package/chat
 $(call Package/ppp/Default)
   DEPENDS:=ppp
@@ -143,7 +161,7 @@ define Package/ppp/install
        $(INSTALL_DATA) ./files/etc/ppp/options $(1)/etc/ppp/
        ln -sf /tmp/resolv.conf.ppp $(1)/etc/ppp/resolv.conf
 endef
        $(INSTALL_DATA) ./files/etc/ppp/options $(1)/etc/ppp/
        ln -sf /tmp/resolv.conf.ppp $(1)/etc/ppp/resolv.conf
 endef
-       
+
 define Package/ppp-mod-pppoa/install
        $(INSTALL_DIR) $(1)/usr/lib/pppd/$(PKG_VERSION)
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/lib/pppd/$(PKG_VERSION)/pppoatm.so \
 define Package/ppp-mod-pppoa/install
        $(INSTALL_DIR) $(1)/usr/lib/pppd/$(PKG_VERSION)
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/lib/pppd/$(PKG_VERSION)/pppoatm.so \