Upgrade speex, add fixed point for all targets (#1678)
authorFlorian Fainelli <florian@openwrt.org>
Mon, 14 May 2007 21:16:03 +0000 (21:16 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 14 May 2007 21:16:03 +0000 (21:16 +0000)
SVN-Revision: 7236

libs/speex/Makefile
libs/speex/patches/100-compile_fix.patch

index 271cb704c93eec3fb892d8886f5f02c053aa2544..81db45b9cb8b798b96f4e25466bfb0947153cda2 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=speex
-PKG_VERSION:=1.1.8
+PKG_VERSION:=1.1.12
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://us.speex.org/download 
-PKG_MD5SUM:=734892c8ca5e7e835828048a1289a0cc
+PKG_SOURCE_URL:=http://downloads.us.xiph.org/releases/speex/
+PKG_MD5SUM:=1bd6cdf3a0ebabf818cd72a3401e2610
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -39,10 +39,13 @@ define Package/libspeex
   URL:=http://www.speex.org/
 endef
 
+TARGET_LDFLAGS:=$(TARGET_LDFLAGS) -lnotimpl
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
                --enable-static \
+               --enable-fixed-point \
                --disable-oggtest \
        )
 endef
index 6f116b612d0f150d2bee2c18c5a7a2550b557b6a..42a848db184fd4d56ca8b2ee0bc97c65c6a59fc3 100644 (file)
@@ -1,12 +1,13 @@
-diff -ur speex.old/libspeex/Makefile.in speex.dev/libspeex/Makefile.in
---- speex.old/libspeex/Makefile.in     2006-10-14 15:16:02.000000000 -0700
-+++ speex.dev/libspeex/Makefile.in     2006-10-14 15:14:35.000000000 -0700
-@@ -107,7 +107,7 @@
+Binary files speex-1.1.12.orig/libspeex/.Makefile.in.swp and speex-1.1.12/libspeex/.Makefile.in.swp differ
+diff -urN speex-1.1.12.orig/libspeex/Makefile.in speex-1.1.12/libspeex/Makefile.in
+--- speex-1.1.12.orig/libspeex/Makefile.in     2007-05-13 13:18:43.000000000 +0200
++++ speex-1.1.12/libspeex/Makefile.in  2007-05-13 13:19:08.000000000 +0200
+@@ -245,7 +245,7 @@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
  EXTRA_DIST = testenc.c testenc_wb.c testenc_uwb.c testdenoise.c testecho.c
 -INCLUDES = -I$(top_srcdir)/include -I$(top_builddir)/include -I$(top_builddir) @OGG_CFLAGS@
 +INCLUDES = -I$(top_srcdir)/include -I$(top_builddir)/include -I$(top_builddir)
  lib_LTLIBRARIES = libspeex.la
  
+ # Sources for compilation in the library