[package] smartmontools: avoid using space in BUILD_INFO.
authorFlorian Fainelli <florian@openwrt.org>
Mon, 19 Nov 2012 15:30:42 +0000 (15:30 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 19 Nov 2012 15:30:42 +0000 (15:30 +0000)
Fixes build against uClibc++.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 34259

utils/smartmontools/Makefile

index 4c045128f372b9bada0fc133e90ef8fdc0d0b021..674fbc3456bf3056fa5a1d2dd672d44dc903e076 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/uclibc++.mk
 
 PKG_NAME:=smartmontools
 PKG_VERSION:=5.40
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/smartmontools
@@ -68,6 +68,7 @@ endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
+               BUILD_INFO='"(localbuild)"' \
                LD="$(TARGET_CXX)"
 endef