fix motion package
authorMike Baker <mbm@openwrt.org>
Mon, 20 Mar 2006 18:32:11 +0000 (18:32 +0000)
committerMike Baker <mbm@openwrt.org>
Mon, 20 Mar 2006 18:32:11 +0000 (18:32 +0000)
aka - clean up someone elses's mess

SVN-Revision: 3419

openwrt/package/Makefile
openwrt/package/motion/Makefile

index eaf9bf43c90725edc52f8ad2bedbd0a8f8e5abcc..049a47a996b739301ca8d77df50c43854ac45ed7 100644 (file)
@@ -439,7 +439,7 @@ mini_httpd-compile: openssl-compile
 endif
 
 ifneq ($(BR2_PACKAGE_MOTION),)
-motion-compile: libjpeg-compile
+motion-compile: jpeg-compile
 endif
 
 ifneq ($(BR2_PACKAGE_MPD_MP3),)
index 578d35be12689cfaa52e273a60996b988f2ed7f9..1cc30398e0ac3117e382e7f697b8b96f8793d46d 100644 (file)
@@ -35,15 +35,15 @@ $(PKG_BUILD_DIR)/.built:
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               install_prefix="$(PKG_INSTALL_DIR)" \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
        touch $@
 
-$(IPKG_FOO):
-       install -d -m0755 $(IDIR_FOO)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/motion $(IDIR_FOO)/usr/sbin
-       $(RSTRIP) $(IDIR_FOO)
-       $(IPKG_BUILD) $(IDIR_FOO) $(PACKAGE_DIR)
+$(IPKG_MOTION):
+       install -d -m0755 $(IDIR_MOTION)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/motion $(IDIR_MOTION)/usr/bin
+       $(RSTRIP) $(IDIR_MOTION)
+       $(IPKG_BUILD) $(IDIR_MOTION) $(PACKAGE_DIR)
 
 mostlyclean:
        make -C $(PKG_BUILD_DIR) clean