Port tinyproxy to -ng, use the new rc.common stuff
authorFlorian Fainelli <florian@openwrt.org>
Sat, 7 Oct 2006 16:37:39 +0000 (16:37 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 7 Oct 2006 16:37:39 +0000 (16:37 +0000)
SVN-Revision: 4950

net/tinyproxy/Makefile [new file with mode: 0644]
net/tinyproxy/files/tinyproxy.init [new file with mode: 0644]

diff --git a/net/tinyproxy/Makefile b/net/tinyproxy/Makefile
new file mode 100644 (file)
index 0000000..11938b7
--- /dev/null
@@ -0,0 +1,57 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=tinyproxy
+PKG_VERSION:=1.6.3
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/tinyproxy
+PKG_MD5SUM:=bd14d029b12621bcfd7ee71b2f4893da
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/tinyproxy
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=Tinyproxy is a lightweight HTTP and HTTPS proxy.
+  DESCRIPTION:=\
+       Tinyproxy is a lightweight HTTP and HTTPS proxy.\
+  URL:=http://tinyproxy.sourceforge.net
+endef
+
+define Build/Configure
+$(call Build/Configure/Default,\
+       --disable-static \
+       --enable-transparent-proxy \
+)
+endef
+
+define Build/Compile
+$(call Build/Compile/Default,DESTDIR="$(PKG_INSTALL_DIR)" install)
+endef
+
+define Package/tinyproxy/install
+       install -d -m0755 $(1)/usr/sbin \
+                               $(1)/etc/tinyproxy \
+                               $(1)/etc/init.d \
+                               $(1)/var/log \
+                               $(1)/usr/share
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/tinyproxy $(1)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/tinyproxy $(1)/usr/share/
+       $(CP) $(PKG_INSTALL_DIR)/etc/tinyproxy $(1)/etc/
+       $(CP) files/tinyproxy.init $(1)/etc/init.d/tinyproxy
+endef
+
+$(eval $(call BuildPackage,tinyproxy))
diff --git a/net/tinyproxy/files/tinyproxy.init b/net/tinyproxy/files/tinyproxy.init
new file mode 100644 (file)
index 0000000..389c238
--- /dev/null
@@ -0,0 +1,17 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2006 OpenWrt.org
+
+BIN=tinyproxy
+DEFAULT=/etc/default/$BIN
+RUN_D=/var/run
+PID_F=$RUN_D/$BIN.pid
+[ -f $DEFAULT ] && . $DEFAULT
+
+start() {
+        mkdir -p $RUN_D
+        $BIN $OPTIONS
+}
+
+stop() {
+        [ -f $PID_F ] && kill $(cat $PID_F)
+}