BB: px5g-standalone: use /dev/urandom to initialize serial (#18232)
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 27 Oct 2014 11:09:37 +0000 (11:09 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 27 Oct 2014 11:09:37 +0000 (11:09 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Backport of r43080

SVN-Revision: 43083

package/utils/px5g-standalone/Makefile
package/utils/px5g-standalone/src/library/x509write.c

index fc5f391bf7d2de68f5a6536b276866583c517c41..d6843b0137f7dd3e90c1998bdcb55dc2e70b2871 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 Jo-Philipp Wich <xm@subsignal.org>
+# Copyright (C) 2010-2014 Jo-Philipp Wich <xm@subsignal.org>
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=px5g
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 PKG_CHECK_FORMAT_SECURITY:=0
index fabee20ea65a7f5eb16fdf86201b350cb6ed574d..10915687459d0ba58ff38184d0df568336b92615 100644 (file)
@@ -999,6 +999,26 @@ static int x509write_make_sign(x509_raw *chain, rsa_context *privkey)
                   (unsigned char*)"", 0);
 }
 
+/*
+ * Create a random serial
+ */
+static int get_random_serial(void)
+{
+    int random = 0;
+    FILE *fd;
+
+    fd = fopen("/dev/urandom", "r");
+
+    if (fd) {
+       if (fread(&random, 1, sizeof(random), fd) != sizeof(random))
+            random = 0;
+
+        fclose(fd);
+    }
+
+    return random;
+}
+
 /*
  * Create a self signed certificate
  */
@@ -1020,8 +1040,11 @@ int x509write_create_sign(x509_raw *chain, rsa_context *privkey)
     /*
      *  CertificateSerialNumber  ::=  INTEGER
      */
-    srand((unsigned int) time(NULL));
-    serial = rand();
+    serial = get_random_serial();
+
+    if (serial == 0)
+        return 1;
+
     if ((ret = asn1_add_int(serial, &chain->serial)) != 0)
         return ret;