Update chrony to 1.23 (#3644)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 6 Jul 2008 11:51:30 +0000 (11:51 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 6 Jul 2008 11:51:30 +0000 (11:51 +0000)
SVN-Revision: 11691

net/chrony/Makefile
net/chrony/patches/001-crosscompile.patch
net/chrony/patches/002-mips_ioc_constants.patch
net/chrony/patches/003-gcc4.patch

index 090cdadd5c10d8405580bdb7ae80219ebf60c56d..7c5d552b7e0eb23bac57b35ac6fb00dce0a7baae 100644 (file)
@@ -9,15 +9,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=chrony
-PKG_VERSION:=1.21
-PKG_RELEASE:=2
+PKG_VERSION:=1.23
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= ftp://chrony.sunsite.dk/projects/chrony/ \
        http://chrony.sunsite.dk/download/
-PKG_MD5SUM:=84f76a73dff5a3c9e9f11f3c29a4e93b
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=ffce77695e55d8efda19ab0b78309c23
 
 include $(INCLUDE_DIR)/package.mk
 
index 0c968a11d7b3d701e5fe3ddd89455ec3dc9b18e1..cdc5939b34eab70e8908147aba3488fca6110fad 100644 (file)
@@ -1,7 +1,6 @@
-diff -ru chrony-1.21.orig/configure chrony-1.21/configure
---- chrony-1.21.orig/configure 2005-08-11 22:32:54.000000000 +0200
-+++ chrony-1.21/configure      2006-08-08 22:24:39.000000000 +0200
-@@ -185,6 +185,13 @@
+--- a/configure
++++ b/configure
+@@ -187,6 +187,13 @@
      --prefix=* | --install_prefix=* )
        INSTALL_PREFIX=`echo $option | sed -e 's/[^=]*=//;'`
      ;;
@@ -15,12 +14,12 @@ diff -ru chrony-1.21.orig/configure chrony-1.21/configure
      --trace )
        EXTRA_DEFS="-DTRACEON"
      ;;
-@@ -237,7 +244,7 @@
+@@ -242,7 +249,7 @@
          ;;
      esac
      ;;
 -    Linux* )
 +    Linux* | linux* )
-         EXTRA_OBJECTS="sys_linux.o wrap_adjtimex.o rtc_linux.o"
-         SYSDEFS="-DLINUX"
-         echo "Configuring for " $SYSTEM
+         EXTRA_OBJECTS="sys_linux.o wrap_adjtimex.o"
+         if [ $feat_rtc -eq 1 ] ; then
+             EXTRA_OBJECTS+=" rtc_linux.o"
index c25bd31d09b16d59aa9392ef618ac5141586910c..e69de29bb2d1d6434b8b29ae775ad8c2e48c5391 100644 (file)
@@ -1,19 +0,0 @@
-diff -ru chrony-1.21.orig/io_linux.h chrony-1.21/io_linux.h
---- chrony-1.21.orig/io_linux.h        2005-08-11 22:32:54.000000000 +0200
-+++ chrony-1.21/io_linux.h     2006-08-08 22:24:43.000000000 +0200
-@@ -24,6 +24,15 @@
- #define CHRONY_IOC_NONE        1U
- #define CHRONY_IOC_READ        2U
- #define CHRONY_IOC_WRITE       4U
-+#elif defined(__mips__) || (__powerpc__) || (__arm__)
-+#define CHRONY_IOC_NRBITS     8
-+#define CHRONY_IOC_TYPEBITS   8
-+#define CHRONY_IOC_SIZEBITS   13
-+#define CHRONY_IOC_DIRBITS    3
-+
-+#define CHRONY_IOC_NONE        1U
-+#define CHRONY_IOC_READ        2U
-+#define CHRONY_IOC_WRITE       4U
- #else
- #error "I don't know the values of the _IOC_* constants for your architecture"
- #endif
index b92268c64a801cbef743c96fe5da43a6a34e3db7..e69de29bb2d1d6434b8b29ae775ad8c2e48c5391 100644 (file)
@@ -1,20 +0,0 @@
---- chrony-1.21/addrfilt.c.orig        2005-08-11 22:32:54.000000000 +0200
-+++ chrony-1.21/addrfilt.c     2005-09-04 11:05:54.000000000 +0200
-@@ -45,7 +45,7 @@
- struct _TableNode;
--typedef struct _TableNode ExtendedTable[TABLE_SIZE];
-+typedef struct _TableNode *ExtendedTable;
- typedef enum {DENY, ALLOW, AS_PARENT} State;
-@@ -124,7 +124,7 @@
-   if (node->extended == NULL) {
--    node->extended = MallocNew(ExtendedTable);
-+    node->extended = MallocArray(ExtendedTable, TABLE_SIZE);
-     for (i=0; i<TABLE_SIZE; i++) {
-       child_node = &((*(node->extended))[i]);