introduce a new logic to handle release numbers when a significant change is made...
authorNicolas Thill <nico@openwrt.org>
Tue, 21 Apr 2009 11:38:28 +0000 (11:38 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 21 Apr 2009 11:38:28 +0000 (11:38 +0000)
 - release packages get a "patch level" added to their release number, this last one being incremented on every change ;
 - trunk packages should always get their release number incremented.

SVN-Revision: 15321

Xorg/driver/xf86-input-tslib/Makefile
Xorg/xorg/xserver/xorg-kdrive/Makefile
Xorg/xorg/xserver/xorg-server/Makefile
libs/net-snmp/Makefile
net/asterisk-1.6.x/Makefile
net/bind/Makefile
net/mini_snmpd/Makefile
net/openvpn/Makefile
net/stun/Makefile

index fb135e8902fb862502eeaa43eac920e7e9130be9..f10e853c4a302de858783b5d55eac3fc10327639 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xf86-input-tslib
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_VERSION:=0.0.5
 
 PKG_SOURCE_URL:=http://www.pengutronix.de/software/xf86-input-tslib/download/
index 465e86351ee871d9a6c5e810646a9cd26c44626c..6732452b03e93b29776c7fb0f1f899518089c98d 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xserver-kdrive
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_VERSION:=1.5.1
 PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.4/src/xserver/
 PKG_SOURCE:=xorg-server-$(PKG_VERSION).tar.bz2
index 8743331392cbe17ed29998a9c1ac46c61caa1d3d..f9b43bd2bff0bf70d8bcb31b6608fd7e865ba0fb 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xorg-server
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_VERSION:=1.5.1
 PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.4/src/xserver/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index b517834386d0b8fb4666f03e1ced0e341709e460..a8ab3c11f88d2e24e170c534548925e8ca3e4164 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=net-snmp
 PKG_VERSION:=5.1.2
-PKG_RELEASE:=2.4
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/net-snmp
index 5734b0cd753cbb07ea3c1e705367d06644091a94..1172d677b9e158f95007c532b744cf4d7701d429 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=asterisk
 PKG_VERSION:=1.6.1.0-rc3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.digium.com/pub/asterisk/releases/
index 2dc94fb59452ee3cf03868defec62a227c01c613..1be117644f8d71d113e6b779c3a99738a8d81137 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bind
 PKG_VERSION:=9.5.0-P1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= \
index e14fad547a1b90f36f0c9ba56ecfc0be6a7551d9..6433a1f0c673e3c4f780815370e8b08a28a758b5 100644 (file)
@@ -8,12 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mini_snmpd
-PKG_RELEASE:=1
+PKG_VERSION:=1.0
+PKG_RELEASE:=2
 
 PKG_SOURCE:=mini_snmpd.tar.gz
 PKG_SOURCE_URL:=http://members.aon.at/linuxfreak/linux/
 PKG_MD5SUM:=13f2202ff01ff6b6463989f34f453063
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/mini-snmpd
index 079c86a7845c3ef5291b273b17d12afa0e39a97d..dd3132820926f79ae93315d0436606d3cd3be9f2 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
index bb62816bddcefa396e34fac0bbe3a345dc697ad0..c2397ec1a3e47550bfe283710b3c97b9b488216f 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,6 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=stund
 PKG_VERSION:=0.96
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION)_Aug13.tgz
 PKG_SOURCE_URL:=@SF/stun