httping: fix build with NLS
authorFlorian Fainelli <florian@openwrt.org>
Mon, 5 May 2014 19:31:03 +0000 (19:31 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 5 May 2014 19:31:03 +0000 (19:31 +0000)
v2: INTL support was not at default DEPENDS (broke nossl)

libintl.h was not found when CONFIG_BUILD_NLS was selected
explicit -lintl fixes
undefined reference to `libintl_gettext'

fixes ticket #15816

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 40701

net/httping/Makefile

index 3c0b1ef35a7cd0b1465ca42b6cb0cebce48098bf..b0b41b17db08015dee0518861b37a452a6969b0b 100644 (file)
@@ -26,6 +26,7 @@ define Package/httping/Default
   CATEGORY:=Network
   TITLE:=Httping is like 'ping' but for http-requests
   URL:=http://www.vanheusden.com/httping/
+  DEPENDS:=$(INTL_DEPENDS)
 endef
 
 define Package/httping/Default/description
@@ -60,12 +61,14 @@ endef
 define Build/Configure
 endef
 
+TARGET_LDFLAGS += $(INTL_LDFLAGS) $(if $(INTL_FULL),-lintl)
+
 MAKE_FLAGS += \
        DEBUG="no" \
        FW="no" \
        NC="no" \
        TFO="no"
-       
+
 ifeq ($(BUILD_VARIANT),nossl)
        MAKE_FLAGS += SSL="no"
 endif