[packages_10.03.1] merge r27673, r27678
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 17 Jul 2011 23:38:41 +0000 (23:38 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 17 Jul 2011 23:38:41 +0000 (23:38 +0000)
SVN-Revision: 27679

ipv6/radvd/Makefile
ipv6/radvd/files/radvd.hotplug [new file with mode: 0644]
ipv6/radvd/patches/002-no_libfl.patch [deleted file]

index ee95baba456c1162db4ae8c2974d91b3ababd640..16d377c81ce4e71ce88012f3e22465e5dbbb1140 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=radvd
-PKG_VERSION:=1.7
+PKG_VERSION:=1.8
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://v6web.litech.org/radvd/dist \
                http://download.sourcemage.org/mirror
-PKG_MD5SUM:=5ec417bde33964a07231ddf6353177c8
+PKG_MD5SUM:=50b4cfbdfa04d629d80437fd1d9e2aef
 
 PKG_INSTALL:=1
 
@@ -37,9 +37,6 @@ CONFIGURE_ARGS += \
        --with-logfile=/var/log/radvd.log \
        --with-pidfile=/var/run/radvd.pid
 
-MAKE_FLAGS += \
-       radvd_LDADD=""
-
 define Package/radvd/conffiles
 /etc/config/radvd
 endef
@@ -49,6 +46,8 @@ define Package/radvd/install
        $(INSTALL_CONF) ./files/radvd.config $(1)/etc/config/radvd
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/radvd.init $(1)/etc/init.d/radvd
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+       $(INSTALL_DATA) ./files/radvd.hotplug $(1)/etc/hotplug.d/iface/05-radvd
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/radvd $(1)/usr/sbin/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/radvdump $(1)/usr/sbin/
diff --git a/ipv6/radvd/files/radvd.hotplug b/ipv6/radvd/files/radvd.hotplug
new file mode 100644 (file)
index 0000000..10a7ca8
--- /dev/null
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+if [ "$ACTION" = ifup ]; then
+       killall -HUP radvd 2>/dev/null
+fi
diff --git a/ipv6/radvd/patches/002-no_libfl.patch b/ipv6/radvd/patches/002-no_libfl.patch
deleted file mode 100644 (file)
index 26041b7..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/scanner.l
-+++ b/scanner.l
-@@ -21,6 +21,8 @@
- extern char *conf_file;
-+int yywrap(void) { return 1; }
-+
- int num_lines = 1;
- %}