Add liberation fonts.
authorLars-Peter Clausen <lars@metafoo.de>
Sun, 11 Jan 2009 14:20:36 +0000 (14:20 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Sun, 11 Jan 2009 14:20:36 +0000 (14:20 +0000)
SVN-Revision: 13980

Xorg/font/liberation-fonts-ttf/Makefile [new file with mode: 0644]

diff --git a/Xorg/font/liberation-fonts-ttf/Makefile b/Xorg/font/liberation-fonts-ttf/Makefile
new file mode 100644 (file)
index 0000000..ab37d63
--- /dev/null
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=liberation-fonts
+PKG_RELEASE:=1
+PKG_VERSION:=1.04
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/$(PKG_NAME)-$(PKG_VERSION)/
+PKG_SOURCE_URL:=http://fedorahosted.org/releases/l/i/liberation-fonts/
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/liberation-fonts-ttf
+  SECTION:=xorg-font
+  CATEGORY:=Xorg
+  SUBMENU:=font
+  TITLE:=liberation-fonts-ttf
+  URL:=https://fedorahosted.org/liberation-fonts/
+endef
+
+define Build/Compile
+       true
+endef
+
+define Build/Configure
+       true
+endef
+
+define Package/liberation-fonts-ttf/install
+       $(INSTALL_DIR) $(1)/usr/share/fonts/truetype/liberation
+       $(INSTALL_DATA) \
+        $(PKG_BUILD_DIR)/*.ttf \
+        $(1)/usr/share/fonts/truetype/liberation/
+endef
+
+$(eval $(call BuildPackage,liberation-fonts-ttf))
+