Add httptunnel (#1500)
authorFlorian Fainelli <florian@openwrt.org>
Sat, 24 Mar 2007 10:45:26 +0000 (10:45 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 24 Mar 2007 10:45:26 +0000 (10:45 +0000)
SVN-Revision: 6661

net/httptunnel/Makefile [new file with mode: 0644]

diff --git a/net/httptunnel/Makefile b/net/httptunnel/Makefile
new file mode 100644 (file)
index 0000000..f4e0e61
--- /dev/null
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=httptunnel
+PKG_VERSION:=3.3
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=ftp://ftp.nocrew.org/pub/nocrew/unix/
+PKG_MD5SUM:=493cc0f5f21e9955db27ee9cd9a976d5
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/httptunnel
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libopenssl
+  TITLE:=bidirectional virtual data connection tunnelled in HTTP requests
+  DESCRIPTION:=\
+       httptunnel creates a bidirectional virtual data connection tunnelled in HTTP requests.\\\
+       The HTTP requests can be sent via an HTTP proxy if so desired.
+  URL:=http://www.nocrew.org/software/httptunnel.html
+endef
+
+define Package/httptunnel/install      
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/hts $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/htc $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,httptunnel))