[packages] tor: update to 0.2.1.26, fix log directory
authorStephen Walker <stephendwalker@gmail.com>
Sat, 15 May 2010 11:08:00 +0000 (11:08 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Sat, 15 May 2010 11:08:00 +0000 (11:08 +0000)
SVN-Revision: 21450

net/tor/Makefile
net/tor/files/tor.init

index 684bd25979b88bb518d9c651193cf2b485f8b3db..52655587554de6d8e6d96b9e8088a988af4aaeef 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tor
-PKG_VERSION:=0.2.1.25
+PKG_VERSION:=0.2.1.26
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.torproject.org/dist
-PKG_MD5SUM:=f58540b3c5835ac4f5de1b02bbddc703
+PKG_MD5SUM:=f7b30a144e1da41aa43f496bd47ffba7
 
 PKG_INSTALL:=1
 
index c19d2f24a6845dc8818566f0552fb2b59a5d1d95..2b62945425ad6f659166118573770af9272d08c5 100644 (file)
@@ -13,7 +13,7 @@ RUN_GROUP=$BIN
 
 start() {
        [ -f $DEFAULT ] && . $DEFAULT
-       [ -d $LIB_D ] || mkdir -p $LOG_D
+       [ -d $LOG_D ] || ( mkdir -m 0700 -p $LOG_D && chown $RUN_USER:$RUN_GROUP $LOG_D )
        [ -d $LIB_D ] || ( mkdir -m 0700 -p $LIB_D && chown $RUN_USER:$RUN_GROUP $LIB_D )
        [ -d $RUN_D ] || mkdir -p $RUN_D
        [ -f $PID_F ] || ( touch $PID_F && chown $RUN_USER:$RUN_GROUP $PID_F )