python-gnome-desktop2: turn the libwnck dependency into a conditional dependency
authorFelix Fietkau <nbd@openwrt.org>
Thu, 22 Apr 2010 15:58:53 +0000 (15:58 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 22 Apr 2010 15:58:53 +0000 (15:58 +0000)
this prevents it from being added as a build dependency for the whole package,
as the other part of this package can be built without wnck
fixes builds with the directfb display feature flag

SVN-Revision: 21091

lang/python-gnome-desktop2/Makefile

index addb4097672eebe362fca233c318b13645d6d32c..1162c3285ece32af141af88a6e06ee417b5525d2 100644 (file)
@@ -44,7 +44,7 @@ define Package/python-rsvg
 endef
 
 define Package/python-wnck
-       $(call Package/python-gnome-desktop/Default,libwnck,+libwnck)
+       $(call Package/python-gnome-desktop/Default,libwnck,+PACKAGE_python-wnck:libwnck)
 endef
 
 define Build/Configure