port picocom to buildroot-ng
authorNicolas Thill <nico@openwrt.org>
Mon, 24 Jul 2006 19:05:45 +0000 (19:05 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 24 Jul 2006 19:05:45 +0000 (19:05 +0000)
SVN-Revision: 4272

utils/picocom/Makefile [new file with mode: 0644]

diff --git a/utils/picocom/Makefile b/utils/picocom/Makefile
new file mode 100644 (file)
index 0000000..e91ef3a
--- /dev/null
@@ -0,0 +1,54 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=picocom
+PKG_VERSION:=1.4
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://efault.net/npat/hacks/picocom/dist/
+PKG_MD5SUM:=08fcc5f6bb9e7676a2569386d5ea9f70
+PKG_CAT:=zcat
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/picocom
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=A minimal dumb-terminal emulation program
+  DESCRIPTION:=A minimal dumb-terminal emulation program.\\\
+    As its name suggests, picocom is a minimal dumb-terminal emulation \\\
+    program. It is, in principle, very much like minicom, only it's pico \\\
+    instead of mini! It was designed to serve as a simple, manual, modem \\\
+    configuration, testing, and debugging tool. It has also served (quite \\\
+    well) as a low-tech "terminal-window" to allow operator intervention \\\
+    in PPP connection scripts. It could also prove useful in many other \\\
+    similar tasks.
+  URL:=http://efault.net/npat/hacks/picocom/
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
+               CFLAGS="$(TARGET_CFLAGS) -L$(STAGING_DIR)/usr/lib" \
+               picocom
+endef
+
+define Package/picocom/install
+       install -d -m0755 $(1)/usr/bin
+       install -m0755 $(PKG_BUILD_DIR)/picocom $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,picocom))