mac80211: make rt2x00_soc depend on !rt3883
authorJohn Crispin <john@openwrt.org>
Thu, 4 Jul 2013 13:31:18 +0000 (13:31 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 4 Jul 2013 13:31:18 +0000 (13:31 +0000)
https://dev.openwrt.org/ticket/13777

Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 37162

package/kernel/mac80211/Makefile

index ef10ecab87b394c78bbc6a966fb2eac5c7fc49d7..9b2f54de0b43a4c996219bfbfbf4068a6016a846 100644 (file)
@@ -256,7 +256,7 @@ endef
 
 define KernelPackage/rt2x00-soc
 $(call KernelPackage/rt2x00/Default)
-  DEPENDS+= @TARGET_ramips @!TARGET_ramips_mt7620a +kmod-rt2x00-mmio +kmod-rt2x00-lib
+  DEPENDS+= @TARGET_ramips @!TARGET_ramips_mt7620a @!TARGET_ramips_rt3883 +kmod-rt2x00-mmio +kmod-rt2x00-lib
   TITLE+= (SoC)
   FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/rt2x00/rt2x00soc.ko
   AUTOLOAD:=$(call AutoLoad,26,rt2x00soc)