Add mvprelay (#1262)
authorFlorian Fainelli <florian@openwrt.org>
Tue, 12 Jun 2007 16:36:03 +0000 (16:36 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 12 Jun 2007 16:36:03 +0000 (16:36 +0000)
SVN-Revision: 7591

net/mvprelay/Makefile [new file with mode: 0644]

diff --git a/net/mvprelay/Makefile b/net/mvprelay/Makefile
new file mode 100644 (file)
index 0000000..da778de
--- /dev/null
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mvprelay
+PKG_VERSION:=0.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@openwrt/
+PKG_MD5SUM:=189fb792470c966834d5204705ebee83
+PKG_CAT:=bzcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/mvprelay
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=relays requests from the MVP
+  DESCRIPTION:=\
+       Relays requests from the MediaMVP to the TFTP server    
+  URL:=http://downloads.openwrt.org/sources/
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+       $(TARGET_CC) $(TARGET_CFLAGS) $(PKG_BUILD_DIR)/$(PKG_NAME).c -o $(PKG_BUILD_DIR)/$(PKG_NAME)
+endef
+
+define Package/mvprelay/install        
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,mvprelay))