[package] fix miredo init scripts and bump release number (#5632)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 9 Aug 2009 11:03:08 +0000 (11:03 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 9 Aug 2009 11:03:08 +0000 (11:03 +0000)
SVN-Revision: 17197

ipv6/miredo/Makefile
ipv6/miredo/files/miredo-server.init
ipv6/miredo/files/miredo.init

index d140eb372daa51973f319e79dae9a06344567abe..5b5d50d611d2b9bf02095f6a61808c11a98bc2cb 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=miredo
 PKG_VERSION:=1.1.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_URL:=http://www.remlab.net/files/miredo/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index 4d51370f061287ac97ae01ffc319140122729fde..e5aca5f2685bc217e18578684c823b30fd24320c 100644 (file)
@@ -2,17 +2,12 @@
 # Copyright (C) 2006 OpenWrt.org
 START=50
 
-BIN=miredo-server
-DEFAULT=/etc/default/$BIN
-RUN_D=/var/run
-PID_F=$RUN_D/$BIN.pid
+PID_F=/var/run/miredo-server.pid
 
 start() {
-       [ -f $DEFAULT ] && . $DEFAULT
-       [ -d $RUN_D ] || mkdir -p $RUN_D
-       insmod ipv6
-       insmod tun
-       $BIN $OPTIONS
+       insmod ipv6 2>/dev/null
+       insmod tun 2>/dev/null
+       miredo-server -c /etc/miredo-server.conf
 }
 
 stop() {
index 90e70c48bb531c327ffb46511923bb12d3518e85..74406fb672680d51772c07ce019a8e079b96fbb8 100644 (file)
@@ -2,17 +2,12 @@
 # Copyright (C) 2006 OpenWrt.org
 START=50
 
-BIN=miredo
-DEFAULT=/etc/default/$BIN
-RUN_D=/var/run
-PID_F=$RUN_D/$BIN.pid
+PID_F=/var/run/miredo.pid
 
 start() {
-       [ -f $DEFAULT ] && . $DEFAULT
-       [ -d $RUN_D ] || mkdir -p $RUN_D
-       insmod ipv6
-       insmod tun
-       $BIN $OPTIONS
+       insmod ipv6 2>/dev/null
+       insmod tun 2>/dev/null
+       miredo -c /etc/miredo.conf
 }
 
 stop() {