added light edition of spca5xx driver and the streamin server+web-applet
authorJohn Crispin <john@openwrt.org>
Mon, 4 Jun 2007 18:51:41 +0000 (18:51 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 4 Jun 2007 18:51:41 +0000 (18:51 +0000)
SVN-Revision: 7494

package/spca5xx-le/Makefile [new file with mode: 0644]
package/spca5xx-view/Makefile [new file with mode: 0644]
package/spca5xx-view/files/servfox.config [new file with mode: 0644]
package/spca5xx-view/files/servfox.init [new file with mode: 0644]

diff --git a/package/spca5xx-le/Makefile b/package/spca5xx-le/Makefile
new file mode 100644 (file)
index 0000000..82faba6
--- /dev/null
@@ -0,0 +1,44 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 7137 2007-05-08 18:40:02Z nbd $
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=spca5xx-le
+PKG_VERSION:=1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME).tar.bz2
+PKG_SOURCE_URL:=http://www.acmesystems.it/download/owrt/
+PKG_MD5SUM:=
+PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define KernelPackage/spca5xx-le
+  SUBMENU:=Other modules
+  DEPENDS:=@LINUX_2_6 kmod-videodev @VIDEO_SUPPORT
+  TITLE:=Driver for SPCA5xx based USB cameras (Light Edition)
+  URL:=http://mxhaard.free.fr/
+  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
+  FILES:=$(PKG_BUILD_DIR)/spca5xx.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,90,spca5xx)
+endef
+
+define Build/Compile
+       $(MAKE) -C $(LINUX_DIR) \
+               ARCH="$(LINUX_KARCH)" \
+               CROSS_COMPILE="$(TARGET_CROSS)" \
+               KERNELVERSION="$(KERNEL)" \
+               KERNEL_VERSION="$(LINUX_VERSION)" \
+               KERNELDIR="$(LINUX_DIR)" \
+               SUBDIRS="$(PKG_BUILD_DIR)" \
+               modules
+endef
+
+$(eval $(call KernelPackage,spca5xx-le))
diff --git a/package/spca5xx-view/Makefile b/package/spca5xx-view/Makefile
new file mode 100644 (file)
index 0000000..772655c
--- /dev/null
@@ -0,0 +1,49 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 7006 2007-04-19 12:06:39Z kaloz $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=spca5xx-view
+PKG_VERSION:=1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=spca5xx-view.tar.bz2
+PKG_SOURCE_URL:=http://www.acmesystems.it/download/owrt
+PKG_MD5SUM:=
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/spca5xx-view
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=spca5xx streaming applicaton
+  DEPENDS:=kmod-spca5xx-le libpthread
+  DESCRIPTION:=\
+       This package contains a streaming daemon for spca5xx based webcams 
+  URL:=http://www.acmesystems.it
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR)/servfox/ CFLAGS=$(TARTGET_CFLAGS) CC=$(TARGET_CC) 
+       $(MAKE) -C $(PKG_BUILD_DIR)/servfox/ PREFIX="$(PKG_INSTALL_DIR)" install
+endef
+
+define Package/spca5xx-view/install
+       $(INSTALL_DIR) $(1)/
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)
+       $(INSTALL_DIR) $(1)/www/
+       $(CP) $(PKG_BUILD_DIR)/html-files/* $(1)/www/
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/servfox.config $(1)/etc/config/servfox
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/servfox.init $(1)/etc/init.d/servfox
+endef
+
+$(eval $(call BuildPackage,spca5xx-view))
diff --git a/package/spca5xx-view/files/servfox.config b/package/spca5xx-view/files/servfox.config
new file mode 100644 (file)
index 0000000..3138bba
--- /dev/null
@@ -0,0 +1,4 @@
+config servfox
+       option Device       '/dev/video0'
+       option Port         '7070'
+       option Resolution   '640x480'
diff --git a/package/spca5xx-view/files/servfox.init b/package/spca5xx-view/files/servfox.init
new file mode 100644 (file)
index 0000000..072e595
--- /dev/null
@@ -0,0 +1,31 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2006 OpenWrt.org
+START=90
+
+config_cb() {
+       local cfg="$CONFIG_SECTION"
+       local res
+       local dev
+       local port 
+       local cfgt
+       config_get cfgt "$cfg" TYPE
+
+       case "$cfgt" in
+               servfox)
+                       config_get res $cfg Resolution
+                       config_get dev $cfg Device
+                       config_get port $cfg Port
+
+                       SERVFOX_ARGS="${dev:+-d $dev} ${res:+-s $res} ${port:+-w $port}"
+               ;;
+       esac
+}
+
+start() {
+       config_load servfox 
+       /bin/servfox $SERVFOX_ARGS &
+}
+
+stop() {
+       killall servfox 
+}