more V= fixes
authorFelix Fietkau <nbd@openwrt.org>
Sat, 22 Oct 2005 12:54:17 +0000 (12:54 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 22 Oct 2005 12:54:17 +0000 (12:54 +0000)
SVN-Revision: 2234

openwrt/target/linux/package/Makefile
openwrt/target/linux/package/madwifi/Makefile
openwrt/target/linux/package/openwrt/Makefile

index 6b7a85816c8c144ec069dc9f69eb32b1ddbce234..dc031fc47037b3ba791b43492f49a2c675627fad 100644 (file)
@@ -39,7 +39,7 @@ MAKEOPTS:=    BOARD="$(BOARD)" \
                $(MAKEOPTS) \
                prepare
 
-%-compile: %-prepare 
+%-compile:
        @$(TRACE) target/linux/package/$(patsubst %-compile,%,$@)-compile
        $(MAKE) -C $(patsubst %-compile,%,$@) \
                $(MAKEOPTS) \
index 829eed8f4fa35c674db54e51f614e5935b44a599..2f06a2285a9a3eceb05d15886f59f33078da4b01 100644 (file)
@@ -75,5 +75,5 @@ install-dev: $(STAGING_DIR)/usr/include/madwifi/net80211/ieee80211.h
 uninstall-dev:
        rm -rf $(STAGING_DIR)/usr/include/madwifi
 
-compile: install-dev
-clean: uninstall-dev
+compile-targets: install-dev
+clean-targets: uninstall-dev
index ef2c1cea06690f5d49ec0b0055403de95187b613..f55b91d78bb2df63afeeb09ad8859937f44980d0 100644 (file)
@@ -47,7 +47,7 @@ install: compile openwrt-install
 openwrt-install:
        $(IPKG) install $(IPKG_OPENWRT)
 
-compile: install-dev $(IPKG_OPENWRT)
+compile-targets: install-dev $(IPKG_OPENWRT)
 install-dev:
        mkdir -p $(STAGING_DIR)/usr/include
        cp -fpR ./include/[a-z]* $(STAGING_DIR)/usr/include/