[packages] new package: stm32flash - tool for flashing STM32 controllers
authorFlorian Fainelli <florian@openwrt.org>
Mon, 21 Jan 2013 15:27:34 +0000 (15:27 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 21 Jan 2013 15:27:34 +0000 (15:27 +0000)
Signed-off-by: Michael Heimpold <mhei@heimpold.de>
SVN-Revision: 35268

utils/stm32flash/Makefile [new file with mode: 0644]

diff --git a/utils/stm32flash/Makefile b/utils/stm32flash/Makefile
new file mode 100644 (file)
index 0000000..4779def
--- /dev/null
@@ -0,0 +1,40 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=stm32flash
+PKG_REV:=61
+PKG_VERSION:=r$(PKG_REV)
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://stm32flash.googlecode.com/svn/trunk
+PKG_SOURCE_SUBDIR:=stm32flash-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=$(PKG_REV)
+PKG_SOURCE_PROTO:=svn
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/stm32flash
+  SECTION:=utils
+  CATEGORY:=Utilities
+  URL:=http://code.google.com/p/stm32flash/
+  TITLE:=Firmware flash tool for STM32's serial bootloader
+endef
+
+define Package/stm32flash/description
+  This tool can be used to burn firmware images to STM32 ARM processors
+  using the built-in serial bootloader.
+endef
+
+define Package/stm32flash/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/stm32flash $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,stm32flash))