this patches fixes iproute2 parallel build.
authorTravis Kemen <thepeople@openwrt.org>
Sun, 14 Mar 2010 01:56:33 +0000 (01:56 +0000)
committerTravis Kemen <thepeople@openwrt.org>
Sun, 14 Mar 2010 01:56:33 +0000 (01:56 +0000)
-Raphael

SVN-Revision: 20189

package/iproute2/Makefile

index c7c3e2be5ad0410f7c62527f21b69aadf3318c83..9eec69e41c10d345a9346729dc9747b182dd32d7 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
 PKG_VERSION:=2.6.29-1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://devresources.linux-foundation.org/dev/iproute2/download/
@@ -48,7 +48,7 @@ define Build/Configure
        $(SED) "s,^LIBC_INCLUDE.*,LIBC_INCLUDE=$(STAGING_DIR)/include," \
                $(PKG_BUILD_DIR)/Makefile
        # For now disable compiling of the misc directory because it seems to fail
-       rm -rf $(PKG_BUILD_DIR)/misc 
+       rm -rf $(PKG_BUILD_DIR)/misc
        $(SED) "s, misc,," $(PKG_BUILD_DIR)/Makefile
 endef
 
@@ -59,8 +59,8 @@ MAKE_FLAGS += \
        all tc/tc ip/ip
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR)/netem HOSTCC="$(HOSTCC)" EXTRA_CCOPTS="$(TARGET_CFLAGS)" CFLAGS="-D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall -I ../include -DRESOLVE_HOSTNAMES"
-       $(Build/Compile/Default)
+       $(_SINGLE)$(MAKE) -C $(PKG_BUILD_DIR)/netem HOSTCC="$(HOSTCC)"  EXTRA_CCOPTS="$(TARGET_CFLAGS)" CFLAGS="-D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall -I ../include -DRESOLVE_HOSTNAMES"
+       $(_SINGLE)$(Build/Compile/Default)
 endef
 
 define Build/InstallDev
@@ -90,5 +90,3 @@ endef
 $(eval $(call BuildPackage,ip))
 $(eval $(call BuildPackage,tc))
 $(eval $(call BuildPackage,genl))
-
-