Fix memleaks in driver_broadcom.c (thanks framer99)
authorNicolas Thill <nico@openwrt.org>
Fri, 10 Jun 2005 05:55:28 +0000 (05:55 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 10 Jun 2005 05:55:28 +0000 (05:55 +0000)
SVN-Revision: 1182

openwrt/package/wpa_supplicant/Makefile
openwrt/package/wpa_supplicant/patches/driver_broadcom-memleak.patch [new file with mode: 0644]

index b86034dcb5a7f0f5db3f39452c119b78357fc5b1..cfb6e873d6261a7603770760748d27f9644726ee 100644 (file)
@@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wpa_supplicant
 PKG_VERSION:=0.3.8
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_MD5SUM:=c9ced104f0322f834a84336c293b4b57
 
 PKG_SOURCE_URL:=http://hostap.epitest.fi/releases/
diff --git a/openwrt/package/wpa_supplicant/patches/driver_broadcom-memleak.patch b/openwrt/package/wpa_supplicant/patches/driver_broadcom-memleak.patch
new file mode 100644 (file)
index 0000000..3d295f5
--- /dev/null
@@ -0,0 +1,36 @@
+Fixes some memory leaks in driver_broadom.c
+
+  http://openwrt.org/forum/viewtopic.php?pid=8217#p8217
+
+Thanks Greg (framer99)
+
+--- wpa_supplicant-0.3.8/driver_broadcom.c.orig        2005-01-22 05:35:13.000000000 +0100
++++ wpa_supplicant-0.3.8/driver_broadcom.c     2005-06-10 08:50:14.000000000 +0200
+@@ -289,6 +289,7 @@
+                          wwh->type);
+               break;
+       }
++      free(data.assoc_info.resp_ies);
+ }     
+ static void * wpa_driver_broadcom_init(void *ctx, const char *ifname)
+@@ -449,8 +450,10 @@
+       wsr->count = 0;
+       if (broadcom_ioctl(drv, WLC_SCAN_RESULTS, buf, WLC_IOCTL_MAXLEN) <
+-          0)
++          0) {
++              free(buf);
+               return -1;
++      }
+       memset(results, 0, max_size * sizeof(struct wpa_scan_result));
+@@ -490,6 +493,7 @@
+       wpa_printf(MSG_MSGDUMP, "Received %d bytes of scan results (%d BSSes)",
+                  wsr->buflen, ap_num);
++      free(buf);
+       return ap_num;
+ }