added sdparm and scsi-generic module, from #2481
authorJohn Crispin <john@openwrt.org>
Mon, 8 Oct 2007 21:54:13 +0000 (21:54 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 8 Oct 2007 21:54:13 +0000 (21:54 +0000)
SVN-Revision: 9201

package/kernel/modules/block.mk

index ae64fb6b74a1fc728caa8014d89a76ea83bfc885..497aa3a05e05bdd8a2bd5894c6254848d4935b1e 100644 (file)
@@ -137,6 +137,16 @@ endef
 
 $(eval $(call KernelPackage,scsi-core))
 
+define KernelPackage/scsi-generic 
+  TITLE:=Kernel support for SCSI generic 
+  SUBMENU:=$(EMENU) 
+  KCONFIG:=$(CONFIG_CHR_DEV_SG) 
+  FILES:= \ 
+    $(LINUX_DIR)/drivers/scsi/sg.$(LINUX_KMOD_SUFFIX) 
+  AUTOLOAD:=$(call AutoLoad,65,sg) 
+endef
+
+$(eval $(call KernelPackage,scsi-generic)) 
 
 define KernelPackage/loop
   SUBMENU:=$(BLOCK_MENU)