kernel: kmod-ptp selects a new config symbol
authorJohn Crispin <john@openwrt.org>
Thu, 17 Dec 2015 09:29:34 +0000 (09:29 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 17 Dec 2015 09:29:34 +0000 (09:29 +0000)
since Kernel 3.14
408eccce net: ptp: move PTP classifier in its own file

found while bug search
thx olmari on IRC

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
SVN-Revision: 47923

package/kernel/linux/modules/other.mk

index 9bb9dec2bc448868b91466e3fab6dffeb95910a5..62fdc3cd69395841a5e19509b46e96553a0f8426 100644 (file)
@@ -820,7 +820,9 @@ define KernelPackage/ptp
   SUBMENU:=$(OTHER_MENU)
   TITLE:=PTP clock support
   DEPENDS:=+kmod-pps
-  KCONFIG:=CONFIG_PTP_1588_CLOCK
+  KCONFIG:= \
+       CONFIG_PTP_1588_CLOCK \
+       CONFIG_NET_PTP_CLASSIFY=y
   FILES:=$(LINUX_DIR)/drivers/ptp/ptp.ko
   AUTOLOAD:=$(call AutoLoad,18,ptp,1)
 endef