[packages] perl: add Pod module (closes: #7098), bump release number (missed in ...
authorNicolas Thill <nico@openwrt.org>
Mon, 19 Apr 2010 04:16:25 +0000 (04:16 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 19 Apr 2010 04:16:25 +0000 (04:16 +0000)
SVN-Revision: 21015

lang/perl/Makefile
lang/perl/perlbase.mk

index 67eba986dd2638286fdbe030b64bd9ef25ae604a..d3465c5bb9b17fb3c2039211e2f2afb2168a2622 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=perl
 PKG_VERSION:=5.10.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_MD5SUM:=d2c39b002ebfd2c3c5dba589365c5a71
 
 PKG_SOURCE_URL:=ftp://ftp.cpan.org/pub/CPAN/src/5.0 \
index 14242fef6be5bdcb1d642253cd8496fb637a7d42..ac6070ce5e1b22dd41f1f51823a8f78fc59551bb 100644 (file)
@@ -1173,6 +1173,17 @@ endef
 
 $(eval $(call BuildPackage,perlbase-perlio))
 
+define Package/perlbase-pod
+$(call Package/perlbase-template)
+TITLE:=Pod perl module
+endef
+
+define Package/perlbase-pod/install
+$(call perlmod/Install,$(1),Pod,)
+endef
+
+$(eval $(call BuildPackage,perlbase-pod))
+
 
 define Package/perlbase-posix
 $(call Package/perlbase-template)