add pyusb, from #6767
authorTravis Kemen <thepeople@openwrt.org>
Sun, 14 Mar 2010 22:04:30 +0000 (22:04 +0000)
committerTravis Kemen <thepeople@openwrt.org>
Sun, 14 Mar 2010 22:04:30 +0000 (22:04 +0000)
SVN-Revision: 20223

lang/pyusb/Makefile [new file with mode: 0644]

diff --git a/lang/pyusb/Makefile b/lang/pyusb/Makefile
new file mode 100644 (file)
index 0000000..9f2ca62
--- /dev/null
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=pyusb
+PKG_VERSION:=0.4.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/pyusb
+PKG_MD5SUM:=5667a00af1ac0d5062103b4512e227f8
+PKG_BUILD_DEPENDS:=python
+
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python-package.mk)
+
+define Package/pyusb
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=pyusb
+  URL:=http://pyusb.sourceforge.net
+  DEPENDS:=+python-mini +libusb
+endef
+
+define Package/pyusb/description
+  usb port python bindings
+endef
+
+define Build/Compile
+       $(call Build/Compile/PyMod,,install --prefix="$(PKG_INSTALL_DIR)/usr")
+endef
+
+define Package/pyusb/install
+       $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
+       $(CP) \
+           $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
+           $(1)$(PYTHON_PKG_DIR)
+endef
+
+$(eval $(call BuildPackage,pyusb))