[packages] dibbler: update to 0.8.1
authorStephen Walker <stephendwalker@gmail.com>
Fri, 10 Feb 2012 19:21:21 +0000 (19:21 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Fri, 10 Feb 2012 19:21:21 +0000 (19:21 +0000)
 * switch to uclibcxx
 * add requestor package, init scripts & conffiles
 * drop obsolete patches

SVN-Revision: 30425

ipv6/dibbler/Makefile
ipv6/dibbler/files/dibbler-client.init [new file with mode: 0644]
ipv6/dibbler/files/dibbler-relay.init [new file with mode: 0644]
ipv6/dibbler/files/dibbler-server.init [new file with mode: 0644]
ipv6/dibbler/files/dibbler.init [deleted file]
ipv6/dibbler/patches/001-fix_avr32_compile [deleted file]
ipv6/dibbler/patches/001-uclibcxx.patch [deleted file]

index 7241bfb6c819c42596d27488013a8a0c1cdaf3ef..d429b7fd322e3d92c208cd232df6d6466fb101aa 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,23 +8,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dibbler
-PKG_VERSION:=0.7.3
-PKG_RELEASE:=6
+PKG_VERSION:=0.8.1
+PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-src.tar.gz
-PKG_SOURCE_URL:=http://klub.com.pl/dhcpv6/dibbler/
-PKG_MD5SUM:=39be72da38c2e6d33fd43a2811a276b1
-
-PKG_FIXUP:=libtool
-PKG_LIBTOOL_PATHS:=poslib
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://klub.com.pl/dhcpv6/dibbler
+PKG_MD5SUM:=0e52acedd838c43a264441a933780ead
 
 include $(INCLUDE_DIR)/package.mk
 
-# add dependency on 2.6 since recent dibbler needs <linux/ip_mp_alg.h>
 define Package/dibbler/Default
   SECTION:=ipv6
   CATEGORY:=IPv6
-  DEPENDS:=+libstdcpp +libpthread
+  DEPENDS:=+uclibcxx +libpthread
   TITLE:=Dibbler, a portable DHCPv6 implementation
   URL:=http://klub.com.pl/dhcpv6/
 endef
@@ -35,24 +31,18 @@ define Package/dibbler/Default/description
        autoconfiguration for IPv6.
 endef
 
-define Package/dibbler-poslib
-  $(call Package/dibbler/Default)
-  TITLE+= (helper lib)
-endef
-
-define Package/dibbler-poslib/description
-  $(call Package/dibbler/Default/description)
-  This package contains the pos library.
-endef
-
 define Package/dibbler-client
   $(call Package/dibbler/Default)
   TITLE+= (client)
 endef
 
+define Package/dibbler-client/conffiles
+/etc/dibbler/client.conf
+endef
+
 define Package/dibbler-client/description
-  $(call Package/dibbler/Default/description)
-  This package contains the dibbler client.
+       $(call Package/dibbler/Default/description)
+       This package contains the dibbler client.
 endef
 
 define Package/dibbler-relay
@@ -60,82 +50,86 @@ define Package/dibbler-relay
   TITLE+= (relay)
 endef
 
+define Package/dibbler-relay/conffiles
+/etc/dibbler/relay.conf
+endef
+
 define Package/dibbler-relay/description
-  $(call Package/dibbler/Default/description)
-  This package contains the dibbler relay.
+       $(call Package/dibbler/Default/description)
+       This package contains the dibbler relay.
+endef
+
+define Package/dibbler-requestor
+  $(call Package/dibbler/Default)
+  TITLE+= (requestor)
+endef
+
+define Package/dibbler-requestor/description
+       $(call Package/dibbler/Default/description)
+       This package contains the dibbler requestor.
 endef
 
 define Package/dibbler-server
   $(call Package/dibbler/Default)
-  DEPENDS += +dibbler-poslib
   TITLE+= (server)
 endef
 
+define Package/dibbler-server/conffiles
+/etc/dibbler/server.conf
+endef
+
 define Package/dibbler-server/description
-  $(call Package/dibbler/Default/description)
-  This package contains the dibbler server.
-endef
-
-define Build/Configure
-       (cd $(PKG_BUILD_DIR)/poslib; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="$(TARGET_CPPFLAGS)" \
-               LDFLAGS="$(TARGET_LDFLAGS)" \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_NLS) \
-       );
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               PORT_CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
-               PORT_LDFLAGS="$(TARGET_LDFLAGS)" \
-               DEBUGINFO= \
-               server client relay
-endef
-
-define Package/dibbler-poslib/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/./poslib/poslib/.libs/libposlib.so* $(1)/usr/lib/
+       $(call Package/dibbler/Default/description)
+       This package contains the dibbler server.
 endef
 
+TARGET_CXX = $(STAGING_DIR)/host/bin/g++-uc
+
 define Package/dibbler-client/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/dibbler-client $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/dibbler
+       $(INSTALL_CONF) \
+               $(PKG_BUILD_DIR)/doc/examples/client.conf \
+               $(1)/etc/dibbler/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) \
+               ./files/dibbler-client.init \
+               $(1)/etc/init.d/dibbler-client
 endef
 
 define Package/dibbler-relay/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/dibbler-relay $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/dibbler
+       $(INSTALL_CONF) \
+               $(PKG_BUILD_DIR)/doc/examples/relay.conf \
+               $(1)/etc/dibbler/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) \
+               ./files/dibbler-relay.init \
+               $(1)/etc/init.d/dibbler-relay
+endef
+
+define Package/dibbler-requestor/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/dibbler-requestor $(1)/usr/sbin/
 endef
 
 define Package/dibbler-server/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/dibbler-server $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/dibbler
+       $(INSTALL_CONF) \
+               $(PKG_BUILD_DIR)/doc/examples/server.conf \
+               $(1)/etc/dibbler/
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/dibbler.init $(1)/etc/init.d/
+       $(INSTALL_BIN) \
+               ./files/dibbler-server.init \
+               $(1)/etc/init.d/dibbler-server
 endef
 
-$(eval $(call BuildPackage,dibbler-poslib))
 $(eval $(call BuildPackage,dibbler-client))
 $(eval $(call BuildPackage,dibbler-relay))
+$(eval $(call BuildPackage,dibbler-requestor))
 $(eval $(call BuildPackage,dibbler-server))
diff --git a/ipv6/dibbler/files/dibbler-client.init b/ipv6/dibbler/files/dibbler-client.init
new file mode 100644 (file)
index 0000000..04e8a4d
--- /dev/null
@@ -0,0 +1,13 @@
+#!/bin/sh /etc/rc.common
+
+START=90
+STOP=90
+
+start() {
+       mkdir -p /var/lib/dibbler
+       dibbler-client start
+}
+
+stop() {
+       dibbler-client stop
+}
diff --git a/ipv6/dibbler/files/dibbler-relay.init b/ipv6/dibbler/files/dibbler-relay.init
new file mode 100644 (file)
index 0000000..9f42e22
--- /dev/null
@@ -0,0 +1,13 @@
+#!/bin/sh /etc/rc.common
+
+START=90
+STOP=90
+
+start() {
+       mkdir -p /var/lib/dibbler
+       dibbler-relay start
+}
+
+stop() {
+       dibbler-relay stop
+}
diff --git a/ipv6/dibbler/files/dibbler-server.init b/ipv6/dibbler/files/dibbler-server.init
new file mode 100644 (file)
index 0000000..0a93c2a
--- /dev/null
@@ -0,0 +1,13 @@
+#!/bin/sh /etc/rc.common
+
+START=90
+STOP=90
+
+start() {
+       mkdir -p /var/lib/dibbler
+       dibbler-server start
+}
+
+stop() {
+       dibbler-server stop
+}
diff --git a/ipv6/dibbler/files/dibbler.init b/ipv6/dibbler/files/dibbler.init
deleted file mode 100644 (file)
index 0a93c2a..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-#!/bin/sh /etc/rc.common
-
-START=90
-STOP=90
-
-start() {
-       mkdir -p /var/lib/dibbler
-       dibbler-server start
-}
-
-stop() {
-       dibbler-server stop
-}
diff --git a/ipv6/dibbler/patches/001-fix_avr32_compile b/ipv6/dibbler/patches/001-fix_avr32_compile
deleted file mode 100644 (file)
index 4aa4294..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/poslib/config.sub
-+++ b/poslib/config.sub
-@@ -230,7 +230,7 @@
-       | alpha | alphaev[4-8] | alphaev56 | alphaev6[78] | alphapca5[67] \
-       | alpha64 | alpha64ev[4-8] | alpha64ev56 | alpha64ev6[78] | alpha64pca5[67] \
-       | am33_2.0 \
--      | arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr \
-+      | arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr | avr32 \
-       | c4x | clipper \
-       | d10v | d30v | dlx | dsp16xx \
-       | fr30 | frv \
-@@ -297,7 +297,7 @@
-       | alpha64-* | alpha64ev[4-8]-* | alpha64ev56-* | alpha64ev6[78]-* \
-       | alphapca5[67]-* | alpha64pca5[67]-* | arc-* \
-       | arm-*  | armbe-* | armle-* | armeb-* | armv*-* \
--      | avr-* \
-+      | avr-* | avr32-* \
-       | bs2000-* \
-       | c[123]* | c30-* | [cjt]90-* | c4x-* | c54x-* | c55x-* | c6x-* \
-       | clipper-* | cydra-* \
diff --git a/ipv6/dibbler/patches/001-uclibcxx.patch b/ipv6/dibbler/patches/001-uclibcxx.patch
deleted file mode 100644 (file)
index e6cd006..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -61,7 +61,8 @@
-       -L$(MESSAGES)     -lMsg            \
-       -lClntOptions -lOptions -lLowLevel \
-       -L$(MISC)         -lMisc           \
--      -L$(POSLIB)       $(CLNTPOSLIB)
-+      -L$(POSLIB)       $(CLNTPOSLIB) \
-+      $(CLNT_LIBS)
- server: $(SERVERBIN)
-@@ -93,7 +94,8 @@
-       -L$(MISC)        -lMisc            \
-       -L$(LOWLEVEL)    -lLowLevel        \
-       -L$(IFACEMGR)    -lIfaceMgr        \
--      -L$(POSLIB)      $(SRVPOSLIB)
-+      -L$(POSLIB)      $(SRVPOSLIB) \
-+      $(SRV_LIBS)
- relay: $(RELAYBIN)
-@@ -113,7 +115,8 @@
-       -L$(MESSAGES)    -lMsg          \
-       -L$(MISC)        -lMisc         \
-       -L$(OPTIONS)     -lOptions      \
--      -lMisc -lIfaceMgr -lLowLevel -lRelTransMgr -lRelCfgMgr -lRelMsg -lRelOptions -lOptions
-+      -lMisc -lIfaceMgr -lLowLevel -lRelTransMgr -lRelCfgMgr -lRelMsg -lRelOptions -lOptions \
-+      $(SRV_LIBS)
- requestor: $(REQUESTORBIN)
- $(REQUESTORBIN): includes commonlibs Requestor $(REQUESTORDIRS)