add aircrack package (thanks to Florian Fainelli)
authorNicolas Thill <nico@openwrt.org>
Mon, 17 Oct 2005 18:03:48 +0000 (18:03 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 17 Oct 2005 18:03:48 +0000 (18:03 +0000)
SVN-Revision: 2148

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/aircrack/Config.in [new file with mode: 0644]
openwrt/package/aircrack/Makefile [new file with mode: 0644]
openwrt/package/aircrack/ipkg/aircrack.control [new file with mode: 0644]

index 13da907040fd8234ccef3c50e5017fc1b70356b5..6c0bc5a98fa02f7e8e69fb6f757d8584941ffd80 100644 (file)
@@ -37,6 +37,7 @@ source "package/screen/Config.in"
 comment "Networking"
 source "package/6tunnel/Config.in"
 source "package/aiccu/Config.in"
+source "package/aircrack/Config.in"
 source "package/amwall/Config.in"
 source "package/arpd/Config.in"
 source "package/arptables/Config.in"
index 7b0761363251eb5fc42687dc4f964b14b187fe36..6593baf113b3efd27636ddff5756764ac444c4f3 100644 (file)
@@ -5,6 +5,7 @@ package-:=tcp_wrappers
 package-y:=nvram
 package-$(BR2_PACKAGE_6TUNNEL) += 6tunnel
 package-$(BR2_PACKAGE_AICCU) += aiccu
+package-$(BR2_PACKAGE_AIRCRACK) += aircrack
 package-$(BR2_PACKAGE_AMWALL) += amwall
 package-$(BR2_PACKAGE_ARPD) += arpd
 package-$(BR2_PACKAGE_ARPTABLES) += arptables
diff --git a/openwrt/package/aircrack/Config.in b/openwrt/package/aircrack/Config.in
new file mode 100644 (file)
index 0000000..05e134e
--- /dev/null
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_AIRCRACK
+       tristate "aircrack - a set of tools for auditing wireless networks"
+       default m if CONFIG_DEVEL
+       select BR2_PACKAGE_LIBPTHREAD
+       help
+         aircrack is a set of tools for auditing wireless networks:
+         
+          * aircrack: static WEP and WPA-PSK key cracker
+          * airdecap: decrypts WEP/WPA capture files
+          * aireplay: 802.11 packet injection program
+          * airodump: 802.11 packet capture program
+         
+         http://www.cr0.net:8040/code/network/aircrack/
+         
+
diff --git a/openwrt/package/aircrack/Makefile b/openwrt/package/aircrack/Makefile
new file mode 100644 (file)
index 0000000..ff575dc
--- /dev/null
@@ -0,0 +1,43 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=aircrack
+PKG_VERSION:=2.3
+PKG_RELEASE:=1
+PKG_MD5SUM:=8c0c88abe107ca26d019d8f43958e60a
+
+PKG_SOURCE_URL:=http://www.cr0.net:8040/code/network/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,AIRCRACK,aircrack,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC="$(TARGET_CC)" \
+               CFLAGS="$(TARGET_CFLAGS) -Wall" \
+               CROSS="$(TARGET_CROSS)" \
+               prefix="/usr" \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+       touch $@
+
+$(IPKG_AIRCRACK):
+       install -d -m0755 $(IDIR_AIRCRACK)/usr/bin
+       cp -fpR $(PKG_INSTALL_DIR)/usr/bin/aircrack $(IDIR_AIRCRACK)/usr/bin/
+       cp -fpR $(PKG_INSTALL_DIR)/usr/bin/airdecap $(IDIR_AIRCRACK)/usr/bin/
+       cp -fpR $(PKG_INSTALL_DIR)/usr/bin/aireplay $(IDIR_AIRCRACK)/usr/bin/
+       cp -fpR $(PKG_INSTALL_DIR)/usr/bin/airodump $(IDIR_AIRCRACK)/usr/bin/
+       cp -fpR $(PKG_INSTALL_DIR)/usr/bin/arpforge $(IDIR_AIRCRACK)/usr/bin/
+       $(RSTRIP) $(IDIR_AIRCRACK)
+       $(IPKG_BUILD) $(IDIR_AIRCRACK) $(PACKAGE_DIR)
+
diff --git a/openwrt/package/aircrack/ipkg/aircrack.control b/openwrt/package/aircrack/ipkg/aircrack.control
new file mode 100644 (file)
index 0000000..123f24d
--- /dev/null
@@ -0,0 +1,7 @@
+Package: aircrack
+Priority: optional
+Section: net
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>, Florian Fainelli <florian@alphacore.net>
+Source: buildroot internal
+Depends: libpthread
+Description: A set of tools for auditing wireless networks