shorewall:
authorOliver Ertl <oliver@ertl-net.net>
Tue, 4 Sep 2007 19:58:11 +0000 (19:58 +0000)
committerOliver Ertl <oliver@ertl-net.net>
Tue, 4 Sep 2007 19:58:11 +0000 (19:58 +0000)
 * Update 3.4.3 > 3.4.6 (closes: #2310)
 * Cleanup Makefile
 * Refresh patch

SVN-Revision: 8615

net/shorewall/Makefile
net/shorewall/patches/100-no_man.patch

index 58c7841707cbc8ae030c317397ebfd1d62406790..46a81cdbfe7968eb61908966275f5c662ea93f1e 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,16 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=shorewall
-PKG_VERSION:=3.4.3
-PKG_RELEASE:=1
-PKG_MD5SUM:=4ac779d02d4befc72a0ce1534fbb328d
+PKG_VERSION:=3.4.6
+PKG_RELEASE:=2
 
 PKG_SOURCE_URL:=http://www1.shorewall.net/pub/$(PKG_NAME)/3.4/$(PKG_NAME)-$(PKG_VERSION)/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=ec6a8bd3d6d0468b6302a7725851c39b
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,11 +23,12 @@ define Package/shorewall
   CATEGORY:=Network
   DEPENDS:=+iptables
   TITLE:=Shorewall firewall
-  DESCRIPTION:=\
-       Shorewall Firewall is an iptables-based firewall for Linux.
   URL:=http://www.shorewall.net/
 endef
 
+define define Package/shorewall/description
+ Shorewall Firewall is an iptables-based firewall for Linux.
+endef
 
 define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
@@ -41,10 +38,10 @@ endef
 
 define Package/shorewall/install
        $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/$(PKG_NAME) $(1)/sbin
        $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
        $(INSTALL_DIR) $(1)/usr/share
-       $(INSTALL_BIN) ./files/shorewall.init $(1)/etc/init.d/shorewall
-       $(CP) $(PKG_INSTALL_DIR)/sbin/shorewall $(1)/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/share/shorewall $(1)/usr/share
        $(CP) $(PKG_INSTALL_DIR)/etc/shorewall $(1)/etc
 endef
index 298112d056c3ca7a609a2982bd0bf49c5cdb64dd..0a2fabd9cdc1b0fe6e518994e4f4eb8bde0a38df 100644 (file)
@@ -1,22 +1,24 @@
-diff -ruN shorewall-3.4.3/install.sh shorewall-3.4.3.new/install.sh
---- shorewall-3.4.3/install.sh 2007-04-17 19:16:56.000000000 +0200
-+++ shorewall-3.4.3.new/install.sh     2007-08-01 16:21:24.000000000 +0200
-@@ -677,26 +677,6 @@
- # Install the Man Pages
- #
+Index: shorewall-3.4.6/install.sh
+===================================================================
+--- shorewall-3.4.6.orig/install.sh    2007-09-04 21:51:24.000000000 +0200
++++ shorewall-3.4.6/install.sh 2007-09-04 21:51:24.000000000 +0200
+@@ -676,28 +676,6 @@
+ fi
  
--cd manpages
+ #
+-# Install the Man Pages
+-#
 -
--rm -f *.gz
+-cd manpages
 -
 -for f in *.5; do
--    gzip $f
+-    gzip -c $f > $f.gz
 -    run_install -D  -m 0444 $f.gz ${PREFIX}/usr/share/man/man5/$f.gz
 -    echo "Man page $f.gz installed to /usr/share/man/man5/$f.gz"
 -done
 -
 -for f in *.8; do
--    gzip $f
+-    gzip -c $f > $f.gz
 -    run_install -D  -m 0444 $f.gz ${PREFIX}/usr/share/man/man8/$f.gz
 -    echo "Man page $f.gz installed to /usr/share/man/man8/$f.gz"
 -done
@@ -25,6 +27,7 @@ diff -ruN shorewall-3.4.3/install.sh shorewall-3.4.3.new/install.sh
 -
 -echo "Man Pages Installed"
 -
- #
+-#
  # Install the firewall script
  #
+ install_file firewall ${PREFIX}/usr/share/shorewall/firewall 0555