[packages] transmision: fixup configure, fuzz
authorCezary Jackiewicz <cezary@eko.one.pl>
Sat, 4 Jan 2014 17:03:21 +0000 (17:03 +0000)
committerCezary Jackiewicz <cezary@eko.one.pl>
Sat, 4 Jan 2014 17:03:21 +0000 (17:03 +0000)
while at it remove patch fuzz by refreshing patches

fixes build warning:
configure: WARNING: unrecognized options: --disable-gtk

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
SVN-Revision: 39199

net/transmission/Makefile
net/transmission/patches/010_libtransmission_fallocate64_eglibc.patch

index e5a0a1156f00a600c28eb4a07801376fc4b54b97..7273207ba0e138b512142ffe4e392a74c43d8049 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=transmission
 PKG_VERSION:=2.82
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://mirrors.m0k.org/transmission/files
@@ -81,7 +81,7 @@ CONFIGURE_VARS += \
 CONFIGURE_ARGS += \
        --enable-daemon \
        --enable-cli \
-       --disable-gtk \
+       --without-gtk \
        --enable-largefile \
        --enable-lightweight
 
index 15ae518673349e639b8abe7fa3eeafef60c404c5..afadc24543605b8958cadaf5dcf9e4ff814fd68f 100644 (file)
@@ -1,6 +1,5 @@
-diff -Naur transmission-2.61/libtransmission/fdlimit.c transmission-2.61-new/libtransmission/fdlimit.c
---- transmission-2.61/libtransmission/fdlimit.c        2012-07-24 04:59:03.429474697 +0300
-+++ transmission-2.61-new/libtransmission/fdlimit.c    2012-07-31 14:40:23.999860054 +0300
+--- a/libtransmission/fdlimit.c
++++ b/libtransmission/fdlimit.c
 @@ -25,7 +25,8 @@
   #include <fcntl.h>
  #endif
@@ -9,5 +8,5 @@ diff -Naur transmission-2.61/libtransmission/fdlimit.c transmission-2.61-new/lib
 +/* no need to define fallocate64 in glibc/eglibc case */
 +#if defined(__UCLIBC__) && (HAVE_FALLOCATE64)
    /* FIXME can't find the right #include voodoo to pick up the declaration.. */
-   extern int fallocate64( int fd, int mode, uint64_t offset, uint64_t len );
+   extern int fallocate64 (int fd, int mode, uint64_t offset, uint64_t len);
  #endif