[package] base-files: properly handle vlans on top of wireless interfaces
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 18 Mar 2011 18:24:51 +0000 (18:24 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 18 Mar 2011 18:24:51 +0000 (18:24 +0000)
SVN-Revision: 26230

package/base-files/Makefile
package/base-files/files/etc/hotplug.d/net/10-net

index 5f8a3eaab4272fa7bcefabd233c33431d4d21a37..a4a62d23f5df944359929c08943f1edfaa7c7907 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=67
+PKG_RELEASE:=68
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index 4744a1e8100a8b4c88fe3a33e078320788701839..013ece39ce954acdf5e1611c87fb1c21f1e7c586 100644 (file)
@@ -12,20 +12,23 @@ addif() {
        # PPP devices are configured by pppd, no need to run setup_interface here
        case "$INTERFACE" in
                3g-*|ppp-*|pppoa-*|pppoe-*|pptp-*) return 0;;
-               ath*) return 0;;
-               wlan*) return 0;;
        esac
 
        scan_interfaces
        local cfg="$(find_config "$INTERFACE")"
 
-       # check the autoload setting
-       config_get auto "$cfg" auto
-       case "$auto" in
-               1|on|enabled) setup_interface "$INTERFACE";;
+       case "$INTERFACE" in
+               # Skip wireless parent interfaces
+               ath[0-9]|wlan[0-9]) ;;
+               *)
+                       # check the autoload setting
+                       config_get auto "$cfg" auto
+                       case "$auto" in
+                               1|on|enabled) setup_interface "$INTERFACE";;
+                       esac
+               ;;
        esac
 
-
        # find all vlan configurations for this interface and set them up as well
        for ifc in $interfaces; do
                config_get iftype "$ifc" type