[backfire] merge r23058, refresh patches
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 29 Oct 2010 19:22:45 +0000 (19:22 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 29 Oct 2010 19:22:45 +0000 (19:22 +0000)
SVN-Revision: 23712

target/linux/generic-2.6/patches-2.6.32/007-squashfs_make_lzma_available.patch
target/linux/generic-2.6/patches-2.6.32/014-cfi_fix_amd_extended_table_check.patch
target/linux/generic-2.6/patches-2.6.32/030-pci_disable_common_quirks.patch
target/linux/generic-2.6/patches-2.6.32/090-mtd-m25p80-add-en25f32-chip-support.patch [new file with mode: 0644]
target/linux/generic-2.6/patches-2.6.32/690-phy_rtl8306.patch
target/linux/generic-2.6/patches-2.6.32/840-unable_to_open_console.patch
target/linux/generic-2.6/patches-2.6.32/980-vm_exports.patch
target/linux/generic-2.6/patches-2.6.32/999-use_preinit_as_init.patch

index ca43a98bc3cfd63c43e74fbcfd040017fa2d8706..740247162489f7800117826f2f97f48146e2ff1a 100644 (file)
@@ -65,7 +65,7 @@ Signed-off-by: Phillip Lougher <phillip@lougher.demon.co.uk>
 +#endif
 --- a/include/linux/decompress/mm.h
 +++ b/include/linux/decompress/mm.h
-@@ -53,8 +53,6 @@ static void free(void *where)
+@@ -63,8 +63,6 @@ static void free(void *where)
  
  #define set_error_fn(x)
  
@@ -74,7 +74,7 @@ Signed-off-by: Phillip Lougher <phillip@lougher.demon.co.uk>
  #else /* STATIC */
  
  /* Code active when compiled standalone for use when loading ramdisk: */
-@@ -77,7 +75,6 @@ static void free(void *where)
+@@ -87,7 +85,6 @@ static void free(void *where)
  static void(*error)(char *m);
  #define set_error_fn(x) error = x;
  
index 2618fafeb99abea83e2c607d0ca12f6444670fcb..7010d367b8f25449a593d19fbbe4e69f543ecc2c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/chips/cfi_cmdset_0002.c
 +++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -325,6 +325,8 @@ static struct cfi_fixup fixup_table[] =
+@@ -325,6 +325,8 @@ static struct cfi_fixup fixup_table[] = 
  static void cfi_fixup_major_minor(struct cfi_private *cfi,
                                  struct cfi_pri_amdstd *extp)
  {
@@ -9,7 +9,7 @@
        if (cfi->mfr == CFI_MFR_SAMSUNG && cfi->id == 0x257e &&
            extp->MajorVersion == '0')
                extp->MajorVersion = '1';
-@@ -355,6 +357,9 @@ struct mtd_info *cfi_cmdset_0002(struct
+@@ -355,6 +357,9 @@ struct mtd_info *cfi_cmdset_0002(struct 
        mtd->name    = map->name;
        mtd->writesize = 1;
  
@@ -19,7 +19,7 @@
        if (cfi->cfi_mode==CFI_MODE_CFI){
                unsigned char bootloc;
                /*
-@@ -373,16 +378,24 @@ struct mtd_info *cfi_cmdset_0002(struct
+@@ -373,16 +378,24 @@ struct mtd_info *cfi_cmdset_0002(struct 
  
                cfi_fixup_major_minor(cfi, extp);
  
index 4050cf14c7e0a68cc32b997c2382c6fc128f2b50..2854428e18603748773f4fda3176b6be5b565e74 100644 (file)
@@ -23,7 +23,7 @@
  /* The Mellanox Tavor device gives false positive parity errors
   * Mark this device with a broken_parity_status, to allow
   * PCI scanning code to "skip" this now blacklisted device.
-@@ -1884,7 +1885,9 @@ static void __devinit fixup_rev1_53c810(
+@@ -1887,7 +1888,9 @@ static void __devinit fixup_rev1_53c810(
        }
  }
  DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_NCR, PCI_DEVICE_ID_NCR_53C810, fixup_rev1_53c810);
@@ -33,8 +33,8 @@
  /* Enable 1k I/O space granularity on the Intel P64H2 */
  static void __devinit quirk_p64h2_1k_io(struct pci_dev *dev)
  {
-@@ -2515,6 +2518,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
- DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x150d, quirk_i82576_sriov);
+@@ -2522,6 +2525,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
+ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x1518, quirk_i82576_sriov);
  
  #endif        /* CONFIG_PCI_IOV */
 +#endif /* !CONFIG_PCI_DISABLE_COMMON_QUIRKS */
diff --git a/target/linux/generic-2.6/patches-2.6.32/090-mtd-m25p80-add-en25f32-chip-support.patch b/target/linux/generic-2.6/patches-2.6.32/090-mtd-m25p80-add-en25f32-chip-support.patch
new file mode 100644 (file)
index 0000000..969790e
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/drivers/mtd/devices/m25p80.c
++++ b/drivers/mtd/devices/m25p80.c
+@@ -626,7 +626,8 @@ static struct flash_info __devinitdata m
+       { "mx25l12805d", 0xc22018, 0, 64 * 1024, 256, },
+       { "mx25l12855e", 0xc22618, 0, 64 * 1024, 256, },
+-      /* EON -- en25pxx */
++      /* EON -- en25xxx */
++      { "en25f32", 0x1c3116, 0, 64 * 1024,  64, SECT_4K },
+       { "en25p32", 0x1c2016, 0, 64 * 1024,  64, },
+       { "en25p64", 0x1c2017, 0, 64 * 1024, 128, },
index a8c1cb59f2e264aad9eb8840bfb39c69cccff288..36ce9dfce71a85bc5497cb5e0434b6530cfeb5b5 100644 (file)
@@ -14,7 +14,7 @@
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
 @@ -19,6 +19,7 @@ obj-$(CONFIG_MVSWITCH_PHY)   += mvswitch.o
- obj-$(CONFIG_IP17XX)  += ip17xx.o
+ obj-$(CONFIG_IP17XX_PHY)      += ip17xx.o
  obj-$(CONFIG_REALTEK_PHY)     += realtek.o
  obj-$(CONFIG_AR8216_PHY)      += ar8216.o
 +obj-$(CONFIG_RTL8306_PHY)     += rtl8306.o
index c9a27746893275aefc8f5bebb1431c35b06dbee1..8d90396761391fd154676296b62b09499ad46b4d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/init/main.c
 +++ b/init/main.c
-@@ -812,7 +812,7 @@ static noinline int init_post(void)
+@@ -807,7 +807,7 @@ static noinline int init_post(void)
        numa_default_policy();
  
        if (sys_open((const char __user *) "/dev/console", O_RDWR, 0) < 0)
index 616bb2d54b0fb4fab4bfa789fc6f18dbabc52745..b80eb251983f23a00c10081a2900da7237327982 100644 (file)
@@ -68,7 +68,7 @@
   * macro override instead of weak attribute alias, to workaround
 --- a/kernel/sched.c
 +++ b/kernel/sched.c
-@@ -6105,6 +6105,7 @@ int can_nice(const struct task_struct *p
+@@ -6113,6 +6113,7 @@ int can_nice(const struct task_struct *p
        return (nice_rlim <= p->signal->rlim[RLIMIT_NICE].rlim_cur ||
                capable(CAP_SYS_NICE));
  }
  #ifndef CONFIG_MMU
 --- a/kernel/signal.c
 +++ b/kernel/signal.c
-@@ -1070,6 +1070,7 @@ struct sighand_struct *lock_task_sighand
+@@ -1072,6 +1072,7 @@ struct sighand_struct *lock_task_sighand
  
        return sighand;
  }
index 0a52a87e83ca0835696da255dd89201b4099194b..c1f8ef075e43f6cfd43765b09585ded0262dc15d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/init/main.c
 +++ b/init/main.c
-@@ -836,10 +836,7 @@ static noinline int init_post(void)
+@@ -831,10 +831,7 @@ static noinline int init_post(void)
                printk(KERN_WARNING "Failed to execute %s.  Attempting "
                                        "defaults...\n", execute_command);
        }