fix icecast: rename private libvorbisidec conflicting with the main one (closes:...
authorNicolas Thill <nico@openwrt.org>
Sat, 12 Apr 2008 18:44:18 +0000 (18:44 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 12 Apr 2008 18:44:18 +0000 (18:44 +0000)
SVN-Revision: 10795

net/icecast/Makefile
net/icecast/libvorbisidec.mk

index 62a92192fac65757b421c613340b82614bda029a..23b5a4cd4bdb618a1f414d16bc58479f1c862853 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -16,9 +16,6 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.us.xiph.org/releases/icecast/
 PKG_MD5SUM:=35256fbc4a93571662af2ed18fbbfcc5
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
 include $(INCLUDE_DIR)/package.mk
 
 TREMOR_BUILD_DIR=$(PKG_BUILD_DIR)/libvorbisidec-1.2.0-dave
@@ -27,7 +24,7 @@ TREMOR_DIR=$(TREMOR_BUILD_DIR)/ipkg-install/usr
 define Package/icecast
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libcurl +libvorbisidec +libxml2 +libxslt
+  DEPENDS:=+libcurl +libxml2 +libxslt
   TITLE:=A streaming media server for Ogg/Vorbis and MP3 audio streams
   URL:=http://www.icecast.org/
   SUBMENU:=multimedia
index 6438b12bdb35cecf03e5566e4c5a893d1a4b9440..1c0b36309a53c88d50731d2abde8691d22396db6 100644 (file)
@@ -8,15 +8,15 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_NAME:=libvorbisidec
+PKG_NAME:=icecast-libvorbisidec
 PKG_VERSION:=1.2.0-dave
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=libvorbisidec-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://users.tpg.com.au/davico/openwrt/
 PKG_MD5SUM:=cb8e51aab92ef164f8e0e8853f7164fa
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_BUILD_DIR:=$(BUILD_DIR)/libvorbisidec-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 PATCH_DIR=./patches-libvorbisidec