packages/bandwidthd: use new service functions
authorNicolas Thill <nico@openwrt.org>
Fri, 11 Nov 2011 15:46:29 +0000 (15:46 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 11 Nov 2011 15:46:29 +0000 (15:46 +0000)
SVN-Revision: 28946

utils/bandwidthd/Makefile
utils/bandwidthd/files/bandwidthd.init

index 3121c68d073dea0fb63a7817037785cba14fa56f..3837e25a8182f089ae33a5b0bd8594fbf4954a7d 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bandwidthd
 PKG_VERSION:=2.0.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/bandwidthd
index 3b3819ddd4ee67a819c916706ad3fae33d018da7..6483daa2c00b97f7ca7927cea5d6ec88768229a6 100644 (file)
@@ -1,5 +1,6 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
+
 START=99
 
 config_cb() {
@@ -79,9 +80,9 @@ start() {
                unset conffile
        done
        cd /
-       bandwidthd
+       service_start /usr/sbin/bandwidthd
 }
 
 stop() {
-       killall bandwidthd
+       service_stop /usr/sbin/bandwidthd
 }