[packages] babeld: new upstream release 1.3.1
authorGabriel Kerneis <kerneis@pps.jussieu.fr>
Sat, 11 Feb 2012 15:17:16 +0000 (15:17 +0000)
committerGabriel Kerneis <kerneis@pps.jussieu.fr>
Sat, 11 Feb 2012 15:17:16 +0000 (15:17 +0000)
11 February 2011: babeld-1.3.1
  * Made the resend logic less aggressive.  This should lead to fewer request
    messages upon link failure, at the cost of somewhat worse behaviour in the
    presence of heavy packet loss.
  * INCOMPATIBLE CHANGE: removed the idle detection functionality (-i).  This
    feature was little used and complicated the code somewhat.
  * Various internal tweaks to bring babeld closer to the Quagga version.

SVN-Revision: 30451

net/babel/Makefile
net/babel/files/babeld.config
net/babel/files/babeld.init

index 88bc6bc70bb7ec7c51aefd623226fbfc21f1f63c..ffa45cc88aa28c1d98d81e26c4f791ec29019d95 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=babeld
-PKG_VERSION:=1.3.0
+PKG_VERSION:=1.3.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.pps.jussieu.fr/~jch/software/files/
-PKG_MD5SUM:=05fc458d159b9b6fbf9c2f2f20eb8291
+PKG_MD5SUM:=bc1cb1924c61b4dad6410e342827e8c5
 
 include $(INCLUDE_DIR)/package.mk
 
index d21a22b16301c500a324788583a59ead40a6f258..ed63a3b5a9b269cbf50ba59f35a430826a2fc717 100644 (file)
@@ -6,9 +6,6 @@ config general
        # option 'state_file' '/var/lib/babel-state'
        # option 'hello_interval' '4'
        # option 'wired_hello_interval' '20'
-       # Enable  detection of idle networks.  This functonality is
-       # experimental, don't use it unless you know what you are doing.
-       ## option 'idle_hello_interval' '0'
        # option 'diversity' '0,128'
        # option 'kernel_priority' '0'
        # Do not use this option unless you know what you are doing, as it can
index 321f979ff72e8f07c2e7aab788935ad024ae85c6..565672010e78d8c66be6fda756d7f611a0f25bea 100755 (executable)
@@ -104,7 +104,6 @@ babel_config() {
        append_parm "$cfg" 'state_file' '-S'
        append_parm "$cfg" 'hello_interval' '-h'
        append_parm "$cfg" 'wired_hello_interval' '-H'
-       append_parm "$cfg" 'idle_hello_interval' '-i'
        append_parm "$cfg" 'diversity' '-z'
        append_parm "$cfg" 'kernel_priority' '-k'
        append_parm "$cfg" 'duplication_priority' '-A'