backport from whiterussian [1371]
authorNicolas Thill <nico@openwrt.org>
Tue, 25 Oct 2005 03:12:26 +0000 (03:12 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 25 Oct 2005 03:12:26 +0000 (03:12 +0000)
SVN-Revision: 2301

openwrt/package/arptables/Makefile

index ceb745040b7255a57f2353107b054a45da21b385..f024e7db153a51b7bd329f5943e73463bc625fd4 100644 (file)
@@ -21,10 +21,12 @@ $(PKG_BUILD_DIR)/.configured:
 $(PKG_BUILD_DIR)/.built: 
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC=$(TARGET_CC) LD=$(TARGET_CROSS)ld \
 $(PKG_BUILD_DIR)/.built: 
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC=$(TARGET_CC) LD=$(TARGET_CROSS)ld \
-               CFLAGS="$(TARGET_CFLAGS) -Wall -I$(PKG_BUILD_DIR)/include/linux/include -I$(PKG_BUILD_DIR)/include -DARPTABLES_VERSION=\\\"$(PKG_VERSION)\\\" "
+               COPT_FLAGS="$(TARGET_CFLAGS)" \
+               KERNEL_DIR="./include/linux"
        touch $@
 
 $(IPKG_ARPTABLES):
        touch $@
 
 $(IPKG_ARPTABLES):
-       mkdir -p $(IDIR_ARPTABLES)/usr/sbin
-       cp $(PKG_BUILD_DIR)/arptables $(IDIR_ARPTABLES)/usr/sbin/
+       install -d -m0755 $(IDIR_ARPTABLES)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/arptables $(IDIR_ARPTABLES)/usr/sbin/
+       $(RSTRIP) $(IDIR_ARPTABLES)
        $(IPKG_BUILD) $(IDIR_ARPTABLES) $(PACKAGE_DIR)
        $(IPKG_BUILD) $(IDIR_ARPTABLES) $(PACKAGE_DIR)