[packages] add udpcast - a file transfer tool that can send data simultaneously to...
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 24 May 2011 09:01:18 +0000 (09:01 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 24 May 2011 09:01:18 +0000 (09:01 +0000)
SVN-Revision: 26980

net/udpcast/Makefile [new file with mode: 0644]

diff --git a/net/udpcast/Makefile b/net/udpcast/Makefile
new file mode 100644 (file)
index 0000000..690ed98
--- /dev/null
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=udpcast
+PKG_RELEASE:=1
+PKG_VERSION:=20100130
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://udpcast.linux.lu/download/
+PKG_MD5SUM:=f9ad942dfe3ecbd2da5d91479957e5a9
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/udpcast
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=UDP Cast
+  URL:=http://udpcast.linux.lu/
+endef
+
+define Package/udpcast/description
+  UDPcast is a file transfer tool that can send data simultaneously to many destinations on a LAN.
+endef
+
+define Package/udpcast/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) \
+               $(PKG_BUILD_DIR)/udp-receiver \
+               $(1)/usr/sbin/
+       $(INSTALL_BIN) \
+               $(PKG_BUILD_DIR)/udp-sender \
+               $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,udpcast))