gcc: add a config option for using the gcc graphite framework (disabled by default)
authorFelix Fietkau <nbd@openwrt.org>
Thu, 12 Nov 2009 13:42:07 +0000 (13:42 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 12 Nov 2009 13:42:07 +0000 (13:42 +0000)
SVN-Revision: 18403

toolchain/gcc/Config.in
toolchain/gcc/Makefile
tools/Makefile

index 6df266173777876d889421943666da32ce88fc31..b19427be0a0c5fa5167760683150877927fb4581 100644 (file)
@@ -50,6 +50,11 @@ endif
 
 endchoice
 
+config GCC_USE_GRAPHITE
+       bool
+       prompt "Compile in support for the new Graphite framework in GCC 4.4+" if TOOLCHAINOPTS
+       depends GCC_VERSION_4_4_1 || GCC_VERSION_4_4_2
+
 config EXTRA_GCC_CONFIG_OPTIONS
        string
        prompt "Additional gcc configure options" if TOOLCHAINOPTS
index 9d865e94d3e439e65972811c4b362e0db919690f..ea103c45392cabd7c2c5e610cea24ae14cedb562 100644 (file)
@@ -90,7 +90,7 @@ GCC_CONFIGURE:= \
                --disable-libmudflap \
                --disable-multilib \
                --disable-nls \
-               $(if $(CONFIG_GCC_VERSION_4_4),--with-host-libstdcxx=-lstdc++) \
+               $(if $(CONFIG_GCC_USE_GRAPHITE),--with-host-libstdcxx=-lstdc++) \
                $(SOFT_FLOAT_CONFIG_OPTION) \
                $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
                $(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 --with-abi=64) \
index 6e5eb24cd3dce632a4c1e5db6d9eec349a3fe56e..b7c7f43db6f98ce253d6430684587ffe72d618de 100644 (file)
@@ -20,7 +20,7 @@ tools-y += firmware-utils patch-cmdline quilt yaffs2
 tools-$(CONFIG_CCACHE) += ccache
 tools-dep += lzma
 
-ifdef CONFIG_GCC_VERSION_4_4
+ifdef CONFIG_GCC_USE_GRAPHITE
   tools-y += ppl cloog
   $(curdir)/cloog/compile := $(curdir)/ppl/install
 endif
@@ -82,5 +82,5 @@ $(curdir)//compile = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/.prepared $($(
 $(curdir)/ := .config prereq
 $(curdir)//install = $(1)/compile
 
-$(eval $(call stampfile,$(curdir),tools,install,,CONFIG_CCACHE CONFIG_powerpc CONFIG_GCC_VERSION_4_3))
+$(eval $(call stampfile,$(curdir),tools,install,,CONFIG_CCACHE CONFIG_powerpc CONFIG_GCC_VERSION_4_3 CONFIG_GCC_USE_GRAPHITE))
 $(eval $(call subdir,$(curdir)))