netatalk: only disable shadow password support if it is disabled globally (#12819)
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 17 Jan 2013 15:25:02 +0000 (15:25 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 17 Jan 2013 15:25:02 +0000 (15:25 +0000)
SVN-Revision: 35198

net/netatalk/Makefile

index 60c106be66b89e78a4e205400176b617636dfa39..e70ad02c872ee72af8216ffd7ce06bec3302af1d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2012 OpenWrt.org
+# Copyright (C) 2009-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=netatalk
 PKG_VERSION:=2.2.1
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/netatalk
@@ -41,7 +41,7 @@ define Package/netatalk/conffiles
 /etc/netatalk/afpd.conf
 endef
 
-TARGET_CFLAGS += -std=gnu99 -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
+TARGET_CFLAGS += -std=gnu99
 TARGET_LDFLAGS += $(LIBRPC)
 
 CONFIGURE_ARGS += \
@@ -61,7 +61,7 @@ CONFIGURE_ARGS += \
        --disable-admin-group \
        --disable-srvloc \
        --disable-zeroconf \
-       --without-shadow \
+       $(if $(CONFIG_SHADOW_PASSWORDS),--with-shadow,--without-shadow) \
        --without-ldap
 
 define Package/netatalk/install