update wpa_supplicant to latest development release (v0.4.5),
authorNicolas Thill <nico@openwrt.org>
Sun, 23 Oct 2005 12:22:13 +0000 (12:22 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 23 Oct 2005 12:22:13 +0000 (12:22 +0000)
add drivers for hostap, madwifi and generic wext.

SVN-Revision: 2275

openwrt/package/wpa_supplicant/Makefile
openwrt/package/wpa_supplicant/files/config
openwrt/package/wpa_supplicant/patches/101-ldflags.patch [new file with mode: 0644]
openwrt/package/wpa_supplicant/patches/102-opt_cflags.patch [new file with mode: 0644]
openwrt/package/wpa_supplicant/patches/103-madwifi.patch [new file with mode: 0644]
openwrt/package/wpa_supplicant/patches/ldflags.patch [deleted file]
openwrt/package/wpa_supplicant/patches/opt_cflags.patch [deleted file]

index 70792fe4ec99d59cb52b81da6620830b1feb709f..e7a10165c058107e6631797adf84f105296d922b 100644 (file)
@@ -3,9 +3,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wpa_supplicant
-PKG_VERSION:=0.3.9
+PKG_VERSION:=0.4.5
 PKG_RELEASE:=1
-PKG_MD5SUM:=113873aafc4fcaa0515841a6f0a17fd0
+PKG_MD5SUM:=28347563119f09fc963bcdf9d16265a3
 
 PKG_SOURCE_URL:=http://hostap.epitest.fi/releases/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -24,7 +24,7 @@ $(PKG_BUILD_DIR)/.configured:
 $(PKG_BUILD_DIR)/.built:
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               CPPFLAGS="-I$(TOPDIR)/package/openwrt/include -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include/madwifi" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
                OPT_FLAGS="$(TARGET_CFLAGS)" \
                KERNEL=$(LINUX_DIR) \
index fe7d269da0037e2dbd1113025b01a78dcceea455..19a0fd3294235ed4c84df1a35083a6c7b303e838 100644 (file)
@@ -1,5 +1,8 @@
 # rather important
 CONFIG_DRIVER_BROADCOM=y
+CONFIG_DRIVER_HOSTAP=y
+CONFIG_DRIVER_MADWIFI=y
+CONFIG_DRIVER_WEXT=y
 CONFIG_IEEE8021X_EAPOL=y
 CONFIG_CTRL_IFACE=y
 
diff --git a/openwrt/package/wpa_supplicant/patches/101-ldflags.patch b/openwrt/package/wpa_supplicant/patches/101-ldflags.patch
new file mode 100644 (file)
index 0000000..b8b6f66
--- /dev/null
@@ -0,0 +1,24 @@
+--- wpa_supplicant-0.3.8/Makefile.orig 2005-05-22 12:37:28.000000000 +0200
++++ wpa_supplicant-0.3.8/Makefile      2005-05-22 12:40:04.000000000 +0200
+@@ -304,7 +304,7 @@
+ OBJS += wpa_supplicant.o wpa.o l2_packet.o drivers.o
+ wpa_supplicant: .config $(OBJS)
+-      $(CC) -o wpa_supplicant $(OBJS) $(LIBS)
++      $(CC) $(LDFLAGS) -o wpa_supplicant $(OBJS) $(LIBS)
+ eapol_test: .config $(OBJS_t)
+       $(CC) -o eapol_test $(OBJS_t) $(LIBS)
+@@ -313,10 +313,10 @@
+       $(CC) -o preauth_test $(OBJS_t2) $(LIBS)
+ wpa_passphrase: $(OBJS_p)
+-      $(CC) -o wpa_passphrase $(OBJS_p) $(LIBS_p)
++      $(CC) $(LDFLAGS) -o wpa_passphrase $(OBJS_p) $(LIBS_p)
+ wpa_cli: $(OBJS_c)
+-      $(CC) -o wpa_cli $(OBJS_c) $(LIBS_c)
++      $(CC) $(LDFLAGS) -o wpa_cli $(OBJS_c) $(LIBS_c)
+ win_if_list: win_if_list.c
+       $(CC) -o $@ win_if_list.c $(CFLAGS) $(LIBS_w)
diff --git a/openwrt/package/wpa_supplicant/patches/102-opt_cflags.patch b/openwrt/package/wpa_supplicant/patches/102-opt_cflags.patch
new file mode 100644 (file)
index 0000000..ec38b73
--- /dev/null
@@ -0,0 +1,12 @@
+--- wpa_supplicant-0.3.8/Makefile.orig 2005-02-14 02:55:47.000000000 +0100
++++ wpa_supplicant-0.3.8/Makefile      2005-05-21 21:06:03.000000000 +0200
+@@ -3,7 +3,8 @@
+ endif
+ ifndef CFLAGS
+-CFLAGS = -MMD -O2 -Wall -g
++OPT_FLAGS = -O2 -g
++CFLAGS = -MMD $(OPT_FLAGS) -Wall
+ endif
+ # Include directories for CVS version
diff --git a/openwrt/package/wpa_supplicant/patches/103-madwifi.patch b/openwrt/package/wpa_supplicant/patches/103-madwifi.patch
new file mode 100644 (file)
index 0000000..3a3119f
--- /dev/null
@@ -0,0 +1,50 @@
+diff -ruN wpa_supplicant-0.4.5-old/driver_madwifi.c wpa_supplicant-0.4.5-new/driver_madwifi.c
+--- wpa_supplicant-0.4.5-old/driver_madwifi.c  2005-09-17 07:36:33.000000000 +0200
++++ wpa_supplicant-0.4.5-new/driver_madwifi.c  2005-10-23 14:08:45.000000000 +0200
+@@ -27,11 +27,19 @@
+ #include "wpa_supplicant.h"
+ #include "wpa.h"
++#include <sys/types.h>
++#include <sys/socket.h>
++#include <linux/types.h>
++#include <linux/socket.h>
++#include <linux/if.h>
++#include <stdint.h>
++#include <linux/if_packet.h>
++#include <linux/netlink.h>
++#include <linux/rtnetlink.h>
++
+ #include <include/compat.h>
+ #include <net80211/ieee80211.h>
+ #ifdef WME_NUM_AC
+-/* Assume this is built against BSD branch of madwifi driver. */
+-#define MADWIFI_BSD
+ #include <net80211/_ieee80211.h>
+ #endif /* WME_NUM_AC */
+ #include <net80211/ieee80211_crypto.h>
+@@ -78,19 +86,19 @@
+                               "ioctl[IEEE80211_IOCTL_SETKEY]",
+                               "ioctl[IEEE80211_IOCTL_GETKEY]",
+                               "ioctl[IEEE80211_IOCTL_DELKEY]",
+-                              NULL,
++                              "ioctl[IEEE80211_IOCTL_SETWMMPARAMS]",
+                               "ioctl[IEEE80211_IOCTL_SETMLME]",
+-                              NULL,
++                              "ioctl[IEEE80211_IOCTL_GETCHANINFO]",
+                               "ioctl[IEEE80211_IOCTL_SETOPTIE]",
+                               "ioctl[IEEE80211_IOCTL_GETOPTIE]",
+                               "ioctl[IEEE80211_IOCTL_ADDMAC]",
+                               NULL,
+                               "ioctl[IEEE80211_IOCTL_DELMAC]",
+-                              NULL,
+-                              "ioctl[IEEE80211_IOCTL_CHANLIST]",
++                              "ioctl[IEEE80211_IOCTL_GETCHANLIST]",
++                              "ioctl[IEEE80211_IOCTL_SETCHANLIST]",
+                       };
+                       if (IEEE80211_IOCTL_SETPARAM <= op &&
+-                          op <= IEEE80211_IOCTL_CHANLIST)
++                          op <= IEEE80211_IOCTL_SETCHANLIST)
+                               perror(opnames[op - SIOCIWFIRSTPRIV]);
+                       else
+                               perror("ioctl[unknown???]");
diff --git a/openwrt/package/wpa_supplicant/patches/ldflags.patch b/openwrt/package/wpa_supplicant/patches/ldflags.patch
deleted file mode 100644 (file)
index b8b6f66..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
---- wpa_supplicant-0.3.8/Makefile.orig 2005-05-22 12:37:28.000000000 +0200
-+++ wpa_supplicant-0.3.8/Makefile      2005-05-22 12:40:04.000000000 +0200
-@@ -304,7 +304,7 @@
- OBJS += wpa_supplicant.o wpa.o l2_packet.o drivers.o
- wpa_supplicant: .config $(OBJS)
--      $(CC) -o wpa_supplicant $(OBJS) $(LIBS)
-+      $(CC) $(LDFLAGS) -o wpa_supplicant $(OBJS) $(LIBS)
- eapol_test: .config $(OBJS_t)
-       $(CC) -o eapol_test $(OBJS_t) $(LIBS)
-@@ -313,10 +313,10 @@
-       $(CC) -o preauth_test $(OBJS_t2) $(LIBS)
- wpa_passphrase: $(OBJS_p)
--      $(CC) -o wpa_passphrase $(OBJS_p) $(LIBS_p)
-+      $(CC) $(LDFLAGS) -o wpa_passphrase $(OBJS_p) $(LIBS_p)
- wpa_cli: $(OBJS_c)
--      $(CC) -o wpa_cli $(OBJS_c) $(LIBS_c)
-+      $(CC) $(LDFLAGS) -o wpa_cli $(OBJS_c) $(LIBS_c)
- win_if_list: win_if_list.c
-       $(CC) -o $@ win_if_list.c $(CFLAGS) $(LIBS_w)
diff --git a/openwrt/package/wpa_supplicant/patches/opt_cflags.patch b/openwrt/package/wpa_supplicant/patches/opt_cflags.patch
deleted file mode 100644 (file)
index ec38b73..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- wpa_supplicant-0.3.8/Makefile.orig 2005-02-14 02:55:47.000000000 +0100
-+++ wpa_supplicant-0.3.8/Makefile      2005-05-21 21:06:03.000000000 +0200
-@@ -3,7 +3,8 @@
- endif
- ifndef CFLAGS
--CFLAGS = -MMD -O2 -Wall -g
-+OPT_FLAGS = -O2 -g
-+CFLAGS = -MMD $(OPT_FLAGS) -Wall
- endif
- # Include directories for CVS version