fix libmpcdec fixed point math (#4715)
authorFelix Fietkau <nbd@openwrt.org>
Sun, 31 May 2009 23:02:15 +0000 (23:02 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 31 May 2009 23:02:15 +0000 (23:02 +0000)
SVN-Revision: 16239

libs/libmpcdec/Makefile
libs/libmpcdec/patches/100-fixed_point.patch [new file with mode: 0644]

index ac8f8cd4c504bf209090b651baf32a3509e3272c..3514d176dce2373d756065aef6d877f4df62c69d 100644 (file)
@@ -31,7 +31,7 @@ define Package/libmpcdec/description
        Musepack decoder library
 endef
 
-TARGET_CFLAGS += $(FPIC) -DMPC_FIXED_POINT
+TARGET_CFLAGS += $(FPIC)
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/mpcdec/
diff --git a/libs/libmpcdec/patches/100-fixed_point.patch b/libs/libmpcdec/patches/100-fixed_point.patch
new file mode 100644 (file)
index 0000000..0f7752f
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/include/mpcdec/math.h
++++ b/include/mpcdec/math.h
+@@ -38,7 +38,7 @@
+ #ifndef _mpcdec_math_h_
+ #define _mpcdec_math_h_
+-//#define MPC_FIXED_POINT
++#define MPC_FIXED_POINT
+ #define MPC_FIXED_POINT_SHIFT 16