linux: fix kmod-fs-nfs to include nfsv3.ko, it was split out of nfs.ko in Linux 3.6
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 4 Feb 2014 12:50:59 +0000 (12:50 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 4 Feb 2014 12:50:59 +0000 (12:50 +0000)
SVN-Revision: 39459

package/kernel/linux/modules/fs.mk

index f7c63020b8575ac482ed4e92b905f119b0b12bc8..60933f21923139b2563d09d02362cd363882a5e4 100644 (file)
@@ -226,8 +226,9 @@ define KernelPackage/fs-nfs
        CONFIG_NFS_USE_LEGACY_DNS=n \
        CONFIG_NFS_USE_NEW_IDMAPPER=n
   FILES:= \
-       $(LINUX_DIR)/fs/nfs/nfs.ko
-  AUTOLOAD:=$(call AutoLoad,40,nfs)
+       $(LINUX_DIR)/fs/nfs/nfs.ko \
+       $(LINUX_DIR)/fs/nfs/nfsv3.ko
+  AUTOLOAD:=$(call AutoLoad,40,nfs nfsv3)
 endef
 
 define KernelPackage/fs-nfs/description