add ahcpd (Ad-Hoc Configuration Protocol daemon)
authorNicolas Thill <nico@openwrt.org>
Mon, 3 Sep 2007 14:13:19 +0000 (14:13 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 3 Sep 2007 14:13:19 +0000 (14:13 +0000)
SVN-Revision: 8594

ipv6/ahcpd/Makefile [new file with mode: 0644]

diff --git a/ipv6/ahcpd/Makefile b/ipv6/ahcpd/Makefile
new file mode 100644 (file)
index 0000000..510062b
--- /dev/null
@@ -0,0 +1,59 @@
+# 
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ahcpd
+PKG_VERSION:=0.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.pps.jussieu.fr/~jch/software/files/
+PKG_MD5SUM:=10779877e69605ab22675b36fbe3b8a4
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ahcpd
+  SECTION:=ipv6
+  CATEGORY:=IPv6
+  TITLE:=Ad-Hoc Configuration Protocol daemon
+  URL:=http://www.pps.jussieu.fr/~jch/software/ahcp/
+  DEPENDS:=+kmod-ipv6 +ip
+endef
+
+define Package/ahcpd/description
+ Ahcpd is a daemon for configuring an IPv6 network using the Ad-Hoc
+ Configuration Protocol (AHCP).  AHCP is designed for wireless mesh
+ networks, where IPv6 autoconfiguration and DHCPv6 do not work, but may
+ also be used on wired networks.
+endef
+
+define Build/Configure
+       ( cd $(PKG_BUILD_DIR); \
+               $(SED) 's,/usr/local/bin/,/usr/lib/ahcp/,g' ahcpd.c ; \
+               $(SED) 's,/usr/local/lib/ahcp/,/usr/lib/ahcp/,g' ahcp-config.sh ; \
+       )
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC="$(TARGET_CC)" \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               all
+endef
+
+define Package/ahcpd/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ahcp-generate{,-address} $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/lib/ahcp
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ahcp-config.sh $(1)/usr/lib/ahcp/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ahcpd $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,ahcpd))