include: unbreak conffiles, postinst & prerm exports
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 24 Oct 2014 09:24:51 +0000 (09:24 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 24 Oct 2014 09:24:51 +0000 (09:24 +0000)
Changeset r43017 reworked the ipkg control metadata generation but broke
the export of conffiles, postinst and prerm defines.

Change the code back to rely on shvar and shexport, this is required to
properly output multiline contents.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 43041

include/package-ipkg.mk

index 13bb7c7d42223edfd1ed465403b9f4b447c03804..77eaeb824f9b67ff3966dfbffa3a3440edfa8162 100644 (file)
@@ -13,10 +13,14 @@ IPKG_BUILD:= \
 
 IPKG_STATE_DIR:=$(TARGET_DIR)/usr/lib/opkg
 
 
 IPKG_STATE_DIR:=$(TARGET_DIR)/usr/lib/opkg
 
+# 1: package name
+# 2: variable name
+# 3: variable suffix
 define BuildIPKGVariable
 ifdef Package/$(1)/$(2)
   $$(IPKG_$(1)) : VAR_$(2)$(3)=$$(Package/$(1)/$(2))
 define BuildIPKGVariable
 ifdef Package/$(1)/$(2)
   $$(IPKG_$(1)) : VAR_$(2)$(3)=$$(Package/$(1)/$(2))
-  $(1)_COMMANDS += echo "$$$$$(2)$(3)" > $(2)$(3);
+  $(call shexport,Package/$(1)/$(2))
+  $(1)_COMMANDS += echo "$$$$$$$$$(call shvar,Package/$(1)/$(2))" > $(2)$(3);
 endif
 endef
 
 endif
 endef