[packages] tor-alpha: update to 0.2.3.2-alpha, enable bufferevents, add fw-helper...
authorStephen Walker <stephendwalker@gmail.com>
Tue, 19 Jul 2011 14:42:40 +0000 (14:42 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Tue, 19 Jul 2011 14:42:40 +0000 (14:42 +0000)
SVN-Revision: 27693

net/tor-alpha/Makefile

index 254205f201cb2d51d671be2207b773b3f3bca7ed..338304f7b9b581db0b358cd12b028fc1709dcd6b 100644 (file)
@@ -8,14 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tor-alpha
-PKG_VERSION:=0.2.2.24-alpha
+PKG_VERSION:=0.2.3.2-alpha
 PKG_RELEASE:=1
 
 PKG_SOURCE:=tor-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://www.torproject.org/dist \
        https://archive.torproject.org/tor-package-archive
-PKG_MD5SUM:=4c1e2c7d778f813d09227433fffe3990
+PKG_MD5SUM:=81a0749c16df3160654f6d20ee5db497
 
+PKG_BUILD_DEPENDS:=libminiupnpc libnatpmp
 PKG_BUILD_DIR:=$(BUILD_DIR)/tor-$(PKG_VERSION)
 PKG_INSTALL:=1
 
@@ -38,7 +39,7 @@ endef
 define Package/tor-alpha
 $(call Package/tor-alpha/Default)
   TITLE:=An anonymous Internet communication system
-  DEPENDS:=+libevent +libopenssl +libpthread +librt +miniupnpc
+  DEPENDS:=+libevent2 +libevent2-openssl +libpthread +librt
 endef
 
 define Package/tor-alpha/description
@@ -46,6 +47,17 @@ $(call Package/tor-alpha/Default/description)
  This package contains the tor daemon.
 endef
 
+define Package/tor-alpha-fw-helper
+$(call Package/tor-alpha/Default)
+  TITLE:=Firewall helper for tor
+  DEPENDS:=+tor-alpha +libminiupnpc +libnatpmp
+endef
+
+define Package/tor-alpha-fw-helper/description
+$(call Package/tor-alpha/Default/description)
+ This package contains a helper for automatically configuring port forwarding.
+endef
+
 define Package/tor-alpha-geoip
 $(call Package/tor-alpha/Default)
   TITLE:=GeoIP db for tor
@@ -101,13 +113,16 @@ CONFIGURE_ARGS += \
        --with-ssl-dir="$(STAGING_DIR)/usr" \
        --enable-upnp \
        --with-libminiupnpc-dir="$(STAGING_DIR)/usr" \
+       --enable-nat-pmp \
+       --with-libnatpmp-dir="$(STAGING_DIR)/usr" \
+       --enable-bufferevents
 
 CONFIGURE_VARS += \
-       CROSS_COMPILE="yes" \
+       CROSS_COMPILE="yes"
 
 # pass CFLAGS again to override -O2 set by configure
 MAKE_FLAGS += \
-       CFLAGS="$(TARGET_CFLAGS)" \
+       CFLAGS="$(TARGET_CFLAGS)"
 
 define Package/tor-alpha/install
        $(INSTALL_DIR) $(1)/usr/sbin
@@ -118,10 +133,16 @@ define Package/tor-alpha/install
        $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/tor/torrc.sample $(1)/etc/tor/torrc
 endef
 
+define Package/tor-alpha-fw-helper/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/tor-fw-helper $(1)/usr/bin/
+endef
+
 define Package/tor-alpha-geoip/install
        $(INSTALL_DIR) $(1)/usr/share/tor
        $(CP) $(PKG_INSTALL_DIR)/usr/share/tor/geoip $(1)/usr/share/tor/
 endef
 
 $(eval $(call BuildPackage,tor-alpha))
+$(eval $(call BuildPackage,tor-alpha-fw-helper))
 $(eval $(call BuildPackage,tor-alpha-geoip))