packages: Fix pps-tools build
authorAndy Boyett <agb@openwrt.org>
Thu, 3 Apr 2008 23:11:41 +0000 (23:11 +0000)
committerAndy Boyett <agb@openwrt.org>
Thu, 3 Apr 2008 23:11:41 +0000 (23:11 +0000)
SVN-Revision: 10730

utils/pps-tools/Makefile

index 3176776963ab1c1c4dec5a3fcb3059075a4dcceb..d152363b3eab8d260b08e9ea9c816a19a71fa633 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -30,14 +30,15 @@ define Package/pps-tools/description
 endef
 
 define Build/InstallDev
 endef
 
 define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_BUILD_DIR)/timepps.h $(1)/usr/include/
 endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
        $(CP) $(PKG_BUILD_DIR)/timepps.h $(1)/usr/include/
 endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -DHAVE_ISC_READER=1 -I ." \
-               BINDIR="/usr/sbin" MANDIR="/usr/man" 
+               CFLAGS="$(TARGET_CFLAGS) -DHAVE_ISC_READER=1 -I$(LINUX_DIR)/include -I ." \
+               BINDIR="/usr/sbin" MANDIR="/usr/man"
 endef
 
 define Package/pps-tools/install
 endef
 
 define Package/pps-tools/install