[packages] ahcpd: cope with empty flag options
authorGabriel Kerneis <kerneis@pps.jussieu.fr>
Wed, 29 Jun 2011 07:30:21 +0000 (07:30 +0000)
committerGabriel Kerneis <kerneis@pps.jussieu.fr>
Wed, 29 Jun 2011 07:30:21 +0000 (07:30 +0000)
SVN-Revision: 27303

ipv6/ahcpd/Makefile
ipv6/ahcpd/files/ahcp.sh

index 1a1f4df231a6d5597e0180c51c38652d0f06c723..b417c60147b30d0dcf0fa12e580b9ea5d8beab28 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ahcpd
 PKG_VERSION:=0.51
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.pps.jussieu.fr/~jch/software/files/
index e909def5304e3ce7bd96a893434cd92f7784b90c..805013c4c2ad97eee9d929794d6387a3b4140f36 100644 (file)
@@ -3,7 +3,7 @@ append_bool() {
        local option="$2"
        local value="$3"
        local _loctmp
-       config_get_bool _loctmp "$section" "$option"
+       config_get_bool _loctmp "$section" "$option" 0
        [ "$_loctmp" -gt 0 ] && append args "$value"
 }