cyrus-sasl: update to version 2.1.23.
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 9 Apr 2011 13:04:01 +0000 (13:04 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 9 Apr 2011 13:04:01 +0000 (13:04 +0000)
Make must be run two times to work around a bug described here:
http://lists.andrew.cmu.edu/pipermail/cyrus-sasl/2008-June/001414.html

SVN-Revision: 26541

libs/cyrus-sasl/Makefile
libs/cyrus-sasl/patches/001-cyrus_sasl_gcc4.patch [deleted file]
libs/cyrus-sasl/patches/200-fix_avr32_compile [deleted file]
libs/cyrus-sasl/patches/200-fix_avr32_compile.patch [new file with mode: 0644]

index c6a1fbc17c4ead89f58658ff0859e7c912b59205..2aa86f143ef91a99c4a68550628080998dd7bd91 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cyrus-sasl
-PKG_VERSION:=2.1.20
+PKG_VERSION:=2.1.23
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://ftp.andrew.cmu.edu/pub/cyrus-mail/
-PKG_MD5SUM:=268ead27f4ac39bcfe17d9e38e0f2977
+PKG_MD5SUM:=2eb0e48106f0e9cd8001e654f267ecbc
 
 PKG_BUILD_DEPENDS:=libopenssl
 PKG_FIXUP = libtool no-autoreconf
@@ -38,6 +38,7 @@ CONFIGURE_ARGS += \
        --disable-checkapop \
        --enable-cram \
        --enable-digest \
+       --without-auth-sasldb \
        --disable-otp \
        --disable-srp \
        --disable-srp-setpass \
@@ -49,7 +50,8 @@ CONFIGURE_ARGS += \
        --disable-login \
        --disable-ntlm \
        --disable-sql \
-       --with-dblib="none" \
+       --disable-ldapdb \
+       --without-dblib \
        --without-gdbm \
        --with-devrandom="/dev/urandom" \
        --without-pam \
@@ -75,6 +77,9 @@ define Build/Compile
                CFLAGS="" \
                CPPFLAGS="" \
                makemd5
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install || \
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
diff --git a/libs/cyrus-sasl/patches/001-cyrus_sasl_gcc4.patch b/libs/cyrus-sasl/patches/001-cyrus_sasl_gcc4.patch
deleted file mode 100644 (file)
index 118b5a4..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- cyrus-sasl-2.1.20/lib/client.c~    2003-11-11 11:26:06.000000000 -0500
-+++ cyrus-sasl-2.1.20/lib/client.c     2005-05-31 22:34:14.000000000 -0400
-@@ -61,7 +61,7 @@
- static cmech_list_t *cmechlist; /* global var which holds the list */
--static sasl_global_callbacks_t global_callbacks;
-+sasl_global_callbacks_t global_callbacks;
- static int _sasl_client_active = 0;
diff --git a/libs/cyrus-sasl/patches/200-fix_avr32_compile b/libs/cyrus-sasl/patches/200-fix_avr32_compile
deleted file mode 100644 (file)
index 4c08c92..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- cyrus-sasl-2.1.20/config/config.sub.orig   2008-04-25 21:22:10.000000000 -0500
-+++ cyrus-sasl-2.1.20/config/config.sub        2008-04-25 21:22:59.000000000 -0500
-@@ -241,7 +241,7 @@
-               | mips64vr5000 | mips64vr5000el | mcore | s390 | s390x \
-               | sparc | sparclet | sparclite | sparc64 | sparcv9 | sparcv9b \
-               | v850 | c4x \
--              | thumb | d10v | d30v | fr30 | avr | openrisc | tic80 \
-+              | thumb | d10v | d30v | fr30 | avr | avr32 | openrisc | tic80 \
-               | pj | pjl | h8500 | z8k)
-               basic_machine=$basic_machine-unknown
-               ;;
diff --git a/libs/cyrus-sasl/patches/200-fix_avr32_compile.patch b/libs/cyrus-sasl/patches/200-fix_avr32_compile.patch
new file mode 100644 (file)
index 0000000..4058a7b
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/config/config.sub
++++ b/config/config.sub
+@@ -241,7 +241,7 @@ case $basic_machine in
+               | mips64vr5000 | mips64vr5000el | mcore | s390 | s390x \
+               | sparc | sparclet | sparclite | sparc64 | sparcv9 | sparcv9b \
+               | v850 | c4x \
+-              | thumb | d10v | d30v | fr30 | avr | openrisc | tic80 \
++              | thumb | d10v | d30v | fr30 | avr | avr32 | openrisc | tic80 \
+               | pj | pjl | h8500 | z8k)
+               basic_machine=$basic_machine-unknown
+               ;;